Disappointed :o(

As I had some issues with my Samsung 128GB USB Key on my Pi3 OSMC box with the latest update (see here) , I ordered a vero4k that I received today.
After updated it to the latest release I hoped that it will able to recognize my USB key… but it’s worst than the Pi (which is able to detect the samsung key after booting). The vero4k kernel don’t even detect that an usb device is connected!? The ‘dmesg’ command don’t say anything after plugin this key :frowning: .
I’m completly disappointed… is there something to do to be able to use this Samsung key with Vero4K ? If not, I think that I will return it :-(. Thank you very much.

PS : This is what a Pi (or a Ubuntu computer) dmesg command return when I plug this flash drive

[ 39.421272] usb 4-2: new SuperSpeed USB device number 2 using xhci_hcd
[ 39.447348] usb 4-2: New USB device found, idVendor=090c, idProduct=1000
[ 39.447356] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 39.447359] usb 4-2: Product: Flash Drive FIT
[ 39.447362] usb 4-2: Manufacturer: Samsung
[ 39.447365] usb 4-2: SerialNumber: 0363016010027325

[ 39.451142] usb-storage 4-2:1.0: USB Mass Storage device detected
[ 39.478027] scsi host7: usb-storage 4-2:1.0
[ 40.930791] scsi 7:0:0:0: Direct-Access Samsung Flash Drive FIT 1100 PQ: 0 ANSI: 6
[ 40.936043] sd 7:0:0:0: Attached scsi generic sg2 type 0
[ 40.940030] sd 7:0:0:0: [sdc] 250609664 512-byte logical blocks: (128 GB/120 GiB)
[ 40.940498] sd 7:0:0:0: [sdc] Write Protect is off
[ 40.940504] sd 7:0:0:0: [sdc] Mode Sense: 43 00 00 00
[ 40.940966] sd 7:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
[ 40.947207] sdc: sdc1

Of course you have tried both USB ports, did you?
Since there is nothing in dmesg it sounds more like a contact issue. Have you tried a short USB extension cord to verify this?


I’m sorry you’re having problems with the device. You can of course return it within 14 days of receipt. I suspect however you won’t need to.

Can you post full debug logs so we can see if the device is being detected?
That’s a small dongle, so as @JimKnopf’s assumption is probably correct; it may not be making contact.

A small cable (probably even provided with the device) will verify if this is the problem.

Also: if the USB doesn’t work on Pi and Vero 4K, then there may be something wrong with the USB.


1 Like

Also: what’s the output of uname -a on your Ubuntu machine?

Thanks for your support.
The problem occurs on both USB ports. But it’s a contact issue (no such issue on every other computers nor on my Pis or on my Beelink TV box with this drive?). Adding a cable between the drive and the port solve the problem … Ouf!
I can keep my vero! Thank you again.

1 Like

Did you push it in properly?
It’s an interesting design; and I wouldn’t be surprised if contact issues were also the reason why it didn’t work correctly on Pi.

If the company supplied a cable, they know the connection may sometimes be dodgy.

I will try to look better this evening this contact issue on the vero.
On the Pi I’m sure it’s not the issue cause the problem occurs only when the drive is connected at boot (it crash the systemd.udev.trigger service and then Pi failed to boot, futhermore this problem only appears since the last OSMC update)… after the boot I can connect it without any problem.

(PS: Sorry for my “frenglish” :wink: )

[EDIT] : @sam_nazarko : you were right! I didn’t push my drive properly. As I’ve installed my vero behind a monitor, I didn’t plugged the key correctly. After removing the vero from his support and plugged my Samsung key looking well the port… it works! And without cable. I’m sorry to disturb you. Thank you very much again.

it can also be that the drive is providing an internal additional drive with drivers for the “Windows” OS to install. I hate these drives, as one has to tweak the linux USB handler to ignore the driver drive and provide the legacy access to the drive.

IMHO, get rid of that USB Drive and get yourself something else.

Hi Smurphy,
No no, this drive works well on several Ubuntu computers (I don’t have any ‘windauze’ computer at home), on several Raspbian Pi and even on a LibreElec Beelink TV Box.

Then I don’t know. Sorry.
I have not issues at all with all 3 Vero’s I have here. They all work (Vero1, Vero 2 and 4k).

I’m beginning to suspect some USB3 plugs don’t play well with USB2 sockets and vice-versa. If I plug my USB3 HDD enclosure in with a USB2 cable it can be flaky.

I’m glad this is now resolved