Disk full error after update, bootloop

I just got the message on my Vero 4k+ that my disk is full after the update and now I can’t access the system anymore, just an eternal sad smiley: Osmc update disk full - YouTube

I’m not sure what to do next, since I can’t access the system

Can you still SSH into the system?

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

We need to see the output of grab-logs -A

1 Like

This is the output: https://paste.osmc.tv/wecajapawo

Since you can still ssh in, post the results of:

du -hs ~osmc/* | paste-log


My intuition is that the mono update is taking up a lot of space. The thing is, I need this update for Radarr to run properly. See: [HOW-TO] Install Radarr v2 - #13 by edjalmo

Edit: Right, it looks like something is clogging up my downloads folder. Looking in to it now

You have a Downloads directory with 12GB of data in it. Delete some stuff from there to free up space.

1 Like

Well, that was embarrassing. Hopefully, when someone will make the same mistake they’ll find the solution in this thread without bothering you guys. Thanks again for the patience and help guys.

You’ve just learned a very useful linux command, du :grinning:

1 Like

Just now realised that it still displays the eternal sad smiley though, what should I do to get back in Kodi?

Logs: https://paste.osmc.tv/ojeyiditoj

Jun 07 22:02:07 osmc mediacenter[496]: Starting Kodi...
Jun 07 22:02:07 osmc sudo[2880]:     root : TTY=unknown ; PWD=/ ; USER=osmc ; ENV=MALLOC_MMAP_THRESHOLD_=8192 LIRC_SOCKET_PATH=/var/run/lirc/lircd ; COMMAND=/usr/lib/kodi/kodi.bin --standalone -fs
Jun 07 22:02:07 osmc sudo[2880]: pam_unix(sudo:session): session opened for user osmc by (uid=0)
Jun 07 22:02:07 osmc sudo[2911]:     root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/bin/journalctl
Jun 07 22:02:07 osmc sudo[2911]: pam_unix(sudo:session): session opened for user root by root(uid=0)
Jun 07 22:02:08 osmc mediacenter[496]: ERROR: Unable to create application. Exiting
Jun 07 22:02:08 osmc kernel: kodi.bin[2887]: unhandled level 1 translation fault (11) at 0x00000000, esr 0x83000005
Jun 07 22:02:08 osmc kernel: pgd = ffffffc05d989000
Jun 07 22:02:08 osmc kernel: [00000000] *pgd=0000000000000000

Have you tried an actual reboot after cleaning up the space?

sudo reboot

If that doesn’t help, post logs again as the last set you posted were incomplete because of the lack of space.

Just now did that, doesn’t help unfortunately. The logs are at: https://paste.osmc.tv/ojeyiditoj

Your profile was corrupted. Try:

sudo systemctl stop mediacenter
rm .kodi/userdata/profiles.xml
sudo systemctl start mediacenter


rm: cannot remove '.kodi/userdata/profiles.xml': No such file or directory

Edit: it was in the following folder: /home/osmc/.kodi/userdata

WOKRING AGAIN! thanks!!! And now… watch The Handmaid’s Tale :slight_smile:

If you had just logged in via ssh running the command I gave you would have worked. You must have been in a different directory.

rm ~osmc/.kodi/userdata/profiles.xml

will work from anywhere.

Thanks for all the support bmillham. I followed the instructions you gave me as far as I know, there was no command to change to a certain directory so that command would work, or am I missing something (asking just out of curiosity)?

If the original command I gave you didn’t work right as you logged in, then there is something odd in your setup. When you first log in, what does



1 Like

It shows /root, probably because I made a root account, that’s probably why I’m a directory higher as well. Another mystery bites the dust, thanks :slight_smile:

Ok, having root enabled is a very bad idea! Why did you do this? Some random tutorial you found googling? I strongly recommend that you disable that account.

1 Like

In all my previous mediacentre setups it was always a neccessity to setup a root account for some of the more advanced stuff so it kind of became a habit, no specific reason here other than te presumption that I might need it one day for the more advanced stuff.