Display problem

Hard to explain, best is to see the picture.

My TV broke and I need to get it repaired or getting new… so, my father lent me some very old Panasonic plasma. Set-top box from tv provider works fine, but vero 4k+ just wont.

Please see picture here https://www.dropbox.com/s/5ipro3ncf6z97it/IMG_2696.jpg

Any ideas :slight_smile: ?
Thank you in advance and cheers

Make sure the TV is set up to receive YUV input and Vero is not set to output RGB.

If that doesn’t help, please post logs.

Is the TV too old for hdmi?

Can you post some logs via My OSMC -> Logs?
What is the make and model of the TV?


TV has 2 HDMI inputs… it is Panasonic TH-42PV70PA, I had to dust it first. :wink:

This is a complete one https://paste.osmc.tv/sirelotiki

I would recommend plugging in a different hdmi device just to make sure you are actually dealing with a Vero issue in the first place.

Thank you for suggestion.
I have plugged Vero to another, newer, TV set and worked great.
Funny thingy is that now, when I have tried then numerous time (many power cycles too), just works again. Actually the only thing different was following your suggestion and conect it to another TV set for a minute.

You mean the Vero is working on the Plasma now? Kinda looked to me like the TV was knackered and I wasn’t seeing anything wrong with the settings on the Vero. These TV’s can die in fits and starts. If it is working now it may not stay that way for too long and it is a very old TV at this point.

And I actually meant to plug a device other than the Vero into the plasma, not the other way round :smile:

In my first post I wrote that TV is working fine with set-top box. :wink:
It was the first thing I have tried. :wink:

1 Like

Ok, so as I thought, Vero is sending RGB instead of YUV colour. I don’t know why, unless you have set that up in rc.local or something. Also it’s sending 10-bit colour when the TV only supports 8-bit. i don’t know why that is either - it should fall back to 8 bit.

If you are comfortable with the commandline, try typing this:

echo 8bitnow | sudo tee /sys/class/amhhdmitx/amhdmitx0/attr

If that works, then add a line to /etc/rc.local by typing

sudo nano /etc/rc.local

then the line to add is:

echo 8bit > /sys/class/amhdmitx/amhdmitx0/attr

Come back if all is not clear.

1 Like

I guess I should have looked at the system log instead of just the settings :face_with_symbols_over_mouth: