DLNA refresh for folder is not working

Hi guys,

I’ve started recently to use DLNA service, to stream my kids collection to my TV through KODI. I’m playing movie, from a folder, which is not added to KODI library, but my TV see all the files there and can play them. So everything works fine, except one, tiny, issue. When I add a new movie to this folder, list of files on TV is not updating. I can see all old files, but nothing I’ve added after.
I’ve tried to turn off and turn on shareing, restarting Vero, updating library - nothing worked

I don’t know how to force KODI to update that folder with current list of files. Any help?


I have the same issue and I have a workaround which works for me, but is is manual.
Go to System-Settings-Services-UPnP/DLNA.
In my setup only Allow remote control via UPnP is allowed but I don’t think it matters.
Now change some other setting, in my case I allow Share my libraries. Then I click Reset above setting to default and then set them exactly as they were before.
If I go to my DLNA source now, I see updated files. Works 100% time for me. Stupid, but the only way working for me.
I think it depends on DLNA server because I have two DLNA servers, one is on my Synology NAS, it does not have this issue. Other is on another RPi using minidlna there and it has this issue every single time.
Hope this helps.

I’ve tried to turn off and turn DLNA on KODI and it didn’t work, but never tried to reset them to default - I’ll try that after coming back to home after work.

Had same issue too. I’ll try resetting thanks.

I’ve tried that and no luck. I even restarted VERO in between, to check if list of files is rebuild during restart and no luck :frowning:

Sorry to hear that. Above steps work for me, no idea what else to suggest.

Yeah resetting didn’t work for me either. I don’t remember having this problem in a previous update. @marosg are you using the latest may update?

Yes, the latest update from May.

I guess this is related: smb file listing cached.

The dir cache was increased from 10 to 50.

Maybe somehow is related, but can’t find how - I don’t have a problem, that folder is not cached, but rather it’s not refreshed :frowning:

The June update is due later today. I’m hoping the update might solve this.

When I add a new movie to this folder, list of files on TV is not updating. I can see all old files, but nothing I’ve added after.

That is for me the definition of viewing cached content :wink:

hi casper thanks for info.

Do you know of any way of resetting the cache or increasing it?

Unfortunately not. But I’ve made a feature request here: Make number of cached directory configurable

1 Like

I rather meant, that Kodi cache only 10 folders, so if my is already cached, why it’s not updated :slight_smile:

I have the same problem a few months to install OSMC in RP3 and now does not update the files upnp me, and it is best to go and deleted files does. Is there any solution? With good I went with raspbmc and RP1. With the June update also happens.