DLNA subtitle support

Why don’t you use NFS or Smb if NFS isn’t available?
Those protocols are far better with less overhead…

OSMC runs Kodi. And you are talking about a new feature in Kodi.
So your question simply answers itself: When Kodi 15 goes final.

There are plans to provide nightly builds of Kodi, but as you understand this will be test builds.

Hi, I guess I was hoping this feature would be fast-tracked. It is so essential its quite surprising that its not been yet.

@Theetjuh: Yes I agree but I have a location with multiple screens and hoping to set up with no authentication for ease of use.

None needed with NFS atleast, just allow your entire subnet to access the volume and your are done.

I use Upnp/dlna charing in kodi to, and a subtitle addon(opensubtitles.org)… works for me…

but even better if it could use the subtitles in the same folder…

Per your advise, I made my first effort at setting up NFS for Kodi. (I only tried SMB before, which works well enough apart from requiring authentication). However, Kodi can only see up to the shared folder, and not subfolders.

I’m using Synology NAS, which has some of these option for NFS server:

  • privilege (my setting: Read Only)
  • squash (No mapping)
  • asynchronous (Enabled)
  • non privileged ports (Enabled)
  • access mounted folders (Disabled)

You have any advice why I cant see subfolders?

It merges cleanly with 14.x so I will merge it for final

Sam

1 Like

I got a Sinology nas as well: Raspberry 2 OSMC + DSM.5 Synology - Problem with NFS:

Try to have a look at your own /etc/exports, but if I think the issue is fixed with all_squash, so you have to change your squash setting.

Thank you Sam, just what I was hoping!

I have adjusted so my exports looks exactly like yours, reboot Diskstation. Still no luck. I’m using OSMC RC, not sure where the problem lies : (

+1 on the lack of (.srt) subtitles when serving media from Synology NAS. Sub files are in same folder as movie file (mix of .mkv, .mp4 and .avi). Running Raspberry Pi 2 with OSMC RC.

When I ran RaspBMC everything worked simply, OSMC seems a lot more intricate for a novice like me.

Any tips would be great.

Use SMB or NFS and your problems are gone regarding no subtitle support.

This should make it to RC2

S

Is there some instruction on how to do this? When I try to connect via SMB it gives me “Error 2: share not available”. When I enable NFS on the shared folder on my Synology and then attempt a connection via NFS from my Pi I can see the parent level folder name in the file list and nothing more.

The ONLY way that I can seem to get access to play my videos is via UPnP, but this does not allow local sub playback.

I am remarkably frustrated. Was so happy that RaspBMC just worked. OSMC may be too technical for me at the moment, but I am ticked off that it seems to have stepped a long away backwards from RaspBMC.

Is there some clear instruction on how to set up a video files share to get subs working?

P.S. You may be able to intuit my frustration when you realise that it has been over two months since I posted. I have just been ignoring the Pi and OSMC because it has been and still is too difficult.

http://kodi.wiki/view/File_sharing

Particularly,

http://kodi.wiki/view/SMB

or

http://kodi.wiki/view/NFS#NFS_sharing_from_commercial_NAS_systems_such_as_Synology_or_QNAP

I got the same nfs issue, no access to subfolders, with my new Synology (ds1815+), with the old one no problem (???)

I resolve this by mapping all users to admin, it lacks security (not so much) but no other solutions seems to work for me.

I’ve done it, with shared folder gui, nfs permissions, in dsm 5.2.

Anyone knows what brands / TV models support KODI SUB over DLNA implementation?

I’ve been discussing this here, with no sucess:

https://forum.kodi.tv/showthread.php?tid=327202
https://forum.kodi.tv/showthread.php?tid=126521

Well you didn’t made yourself friends on the Kodi forum by resurrecting a very old thread. I don’t think you make yourself friends by doing the same here on this forum especially if your topic is not specific to OSMC.

2 Likes

I just did a quick test enabling UPnP in Kodi on my Win 11 PC and played some files on a LG 55UM6910PUC. It was able to play srt subs, either embedded or external, but just the default. The sub settings had a track section but it was greyed out. Maybe a different server could allow for a section when there is more than one? I don’t know and I’m not going to install anything new to find out since I don’t use this feature myself. I would think that this means that any smart TV running a current version of WebOS would support the same.

Then again if you were using Kodi as the player and the server via UPnP then it is able to pickup and play all types of subs internal and external. Or you could just dump the UPnP entirely and get a full proper library with all the art and media information by actually using Kodi. You know, the type of thing people using our OS are normally interested in.

I’m not sure how much traction your going to get asking people on Kodi forums on capabilities of a player other than Kodi. Perhaps you should be asking some place on the web that is more general purpose A/V topics.

1 Like

Thanks for your reply!

I can only select an external SUB only. Selection only works if there are embedded SUBS, but that’s ok!

LG seems to be one of the brands that implements proprietary SUB over DLNA that KODI supports (at least, as you said, all the models with WebOS)

SAMSUNG seems to be the other.

PANSONIC for sure (i have one)