Raspberry 2 OSMC + DSM.5 Synology - Problem with NFS

Hello everyone,

I’m very new with Raspberry OSMC and even with my synology NAS…
I managed to install the lastest version of OSMC on my new Raspberry Pi, everything’s working like a charm…
After that i tried to add a video folder from my DS214+, i tried using both SMB and NFS, i followed all the step from this official guide http://kodi.wiki/view/NFS#Synology

Buy following this guide step by step, i managed to see all my shared folder on my syno but i can’t get any acess to them…

I tried a lot of things including following thoses steps http://raspberrypi.stackexchange.com/questions/22300/mount-nfs-folder-share-on-rpi-from-a-synology-nas

but i still can’t use my RaspBerry PI with my synology : :pensive:

I don’t really know what to do so i’m asking you for a litlle help,

thanks by advance and sorry for my english

This has been mentioned several times before.

You need to set the “insecure” flag on your server side nfs shares.

My /etc/exports looks like:


Thank you for your answer, i’m going to try that as soon as i will get home, sorry if i didn’t look enough for a solution !

Hi there,

NFS mounts should be improved a bit with the Release Candidate. Let me know if you’re still having some trouble.

Read OSMC Release Candidate - OSMC for some more information



i run a clean install of the Release Candidate and then i created new shared folders with new NFS permissions and everythings seems to rune fine :slight_smile:

thank you all for your answer, and thank you sam for this new release !!

i have the same problem like you.
Raspberry pi2 OSM RC2 + DSM5.1 synology
i can see the NFS folder but i can´t enter on it.
It works fine with other SO like openelec

This night i will try to create a new FOLDER, but its a problem for me to re-create all the folders :frowning:

Hi All,

I know the post is already quite old but I was facing the same issue while setting up my Synology on my Raspberry 3 - OSMC.
After some investigation, I was able to access my NAS from my Raspberry via the NFS protocol. The configuration was a bit tricky. Therefore, I’d like to share it with you!

[https://i.imgur.com/3C4tJdz.png] (http://Permissions)

[https://i.imgur.com/5w0YAW4.png](http://NFS configuration)

(Sorry, in French)

The solution for me was to use ‘’ as Client instead of ‘*’ - which is not restrictive in my opinion - thus only people on my local network can access it.
Then, to grant permissions to ‘Everyone’ - just read access.

Finally, I was able to mount the NFS from command line; thus I assumed that it would work from the Pi & indeed, it did the trick!

Hope it can help you!