DNS resolution not working after failed update

This problems started last week when I tried to update my raspi 2 to the hotfix version, before that everything was working as it should.
When I tried to update from April version to that one, the raspi rebooted and entered the blue install screen but after a couple of hours it was still at that point so I rebooted.

Since then everything seemed ok except an error when I tried to update again, it just told me that it failed and that I should report the error here.
Also I noticed that transmission was no longer connecting to the tracker but to me that was a problem with the tracker.
I had some spare time today and tried to get a log uploaded to report the update problem but it fails with no url, then after looking a bit more it seems that dns client is not working anymore, pings return bad address, transmission not working, log upload not working, apt-get shows errors resolving addresses, etc.

I did disable and re enable the wired connection within My OSMC but without any luck, I have been trying to find solutions over the internet but I don’t have /etc/resolv.conf

osmc@osmc:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr b8:27:eb:91:0e:b1
          inet addr:  Bcast:  Mask:
          RX packets:13393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7686 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4045188 (3.8 MiB)  TX bytes:1759216 (1.6 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:67539 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67539 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:5800509 (5.5 MiB)  TX bytes:5800509 (5.5 MiB)

I still have local connection but it seems there is some problem or missing component with dns.

What is output of the following commands:

cat /etc/resolv.conf
ping -c 4
ping -c 4 www.osmc.tv
grab-logs -A

Sorry just read now

So how have you configured your LAN (DHCP or Manual).
As a quick fix do:
sudo nano /etc/resolv.conf
And add nameserver

Ok the /etc/resolv.conf is a sym link to missing file

lrwxrwxrwx 1 root root 28 mar 24 20:52 resolv.conf -> /var/run/connman/resolv.conf

Which pointed me to this discussion: Problem with resolv.conf on NFS root install since march update

And the proper solution seems to be:

sudo unlink /etc/resolv.conf
sudo systemctl restart connman

Now resolv.conf is created with a proper value, I do hope that this is not a general bug as it could cause a lot of issues to people as it is very difficult to identify.

Do you have a nfs-root install?

No, and even after the change, the update from My OSMC starts but still keeps stuck at the blue screen “Checking for updates to install…”


There is no trace in your log file of a dist-upgrade try after you had configured the DNS Server and the Time restored.
Try from command line
sudo apt-get update
sudo apt-get dist-upgrade
after your fixed your DNS server temporary.
Also maybe the debian backports mess up something

I tried to follow your instructions but needed to delete /var/lib/dpkg/lock and that seems to have triggered the update that was stalled, it did finish the update and restarted.
Networking is fine and everything seems to be working, maybe there was a problem in the last install that broke the network and stalled the install process and then when I did disconnect the RPi the lock was left there.