Does the Vero4K+ do audio compression?

As I posted here before, we use the Vero4K+ in a hobby filmclub, where people bring their own produced films. During the reviews/discussion after films are presented, it seems that we often have to make the comment that the balance (background) music vs voice-over is not good. The authors usually say that in other places where they show their movies, it sounded OK.
So, I did a test, playing a small portion of such a movie on the Vero4L+ and the same part on a computer using VLC. Both connected to the same speakerset (M-Audio near field monitor) thru the 3.5mm audio plug, and recorded back with a Rode microphone at 1m distance. Then I normalized both recorded tracks, so the music inbetween the parts where the voice-over was, are at the same level.
It looks like the Vero4K+ is doing some kind of compression, taking down the voice-over with several dB’s (visually around 7-8 dB less than the computer/VLC recording).

This could indeed be a reason why we often have to tell the film maker that his balance music/voiceover is not OK, whilst in reality it probably is.

visuals:
VERO4K+ with Kodi:


Computer with VLC:

Any suggestions on how to resolve this ? I searched through all settings, but could not find anything to avoid this type of compression.

Note: We have to use a simple 2 channel audio approach as the audio system in our theatre is just a simple stereo system, and our members always produce movies with 2 channel audio.

First thing to ask is what do the audio settings on your Vero 4K look like?

I assume you are referring to the Audio tabl in Settings/System:

Audio output Device: Default (AML-MESONAUDIO: HDMI, S/PDIF & analogue)
Number of channels: 2.0
Volume control steps: 90
Allow passthrough: off

And in Settings/Player/language:
Prefer default audio streams: on

That is what I find in the settings section related to audio… Anything else?

Note: I’m running the Vero at the 2022-03 update (and when I try to update, it says “no updates available”).

I just did a test with our old mediaplayer (Medi8ter 600X3D), and get a very similar audio pattern as playing with computer/VLC:

Are we talking about a soundtrack in an AC3 format?

No, it’s AAC… since most of us are not using surround sound for our finished soundtracks, AAC is used almost for all our movies. AAC is considered superior to AC3 for the same bitrate.

Here is what MediaInfo says on the audio of the example from which I took the waveforms show in this thread:

Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Bit rate mode : Variable
Bit rate : 157 kb/s
Maximum bit rate : 256 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 23.5 MiB (1%)
Source stream size : 23.5 MiB (1%)
Language : English

Any chance you could do the same tests with OSMC on RPi or Kodi on a PC? It looks like a Kodi thing rather than a Vero4k thing but it wouldbe good to confirm. Or else upload a typical sound track (as AAC) so we can test.

Are the voiceovers recorded in mono or stereo?

I just installed Kodi on my Win10 machine to test (and recorded back at 1 meter distance with the same microphone as used before). Dynamics are as in the Win10/VLC, and our old Medi8ter media player (meaning: good)… see screenshot:


So it seems KODI is not the problem.

I also upload the same 45 seconds AAC file as in the screen shots posted earlier), in case you want to test something. Deleted

Mono/stereo: it depends… some clubmembers record the voice-overs in stereo, other record in mono. I always work mono, but I do not know what the clubmember, who made the movie I’m using as test, used. As I do not have the original voice recording, I cannot easily detect if he recorded mono or stereo (it’s mixed with background music, so the export is stereo). If this would be vital information, I can ask him.

The transfer you requested has been deleted.

oeps… I noticed that on File.io, if 1 person downloads, the file is deleted. I had tested the download myself after uploading, so it immediately dissappeared. My bad.

I tried again through another service:
DVA (audio only, 45 sec test).aac: Zippyshare.com -

Hope it works this time.

Nope. I get 403 forbidden :frowning:

OMG… seems all of these services are letting me down… so I revert to WeTransfer, which has always done a proper job for me in the past. If this does not work, then I do not know what to do.
https://wetransfer.com/downloads/d570713426461330d60189a69d0de64020220816102227/46b825c1129f04aaf277cda12f49419220220816102243/e7b77b

it’s valid for 7 days, so thru Aug 22 or 23rd (not sure how the 7 days count).

1 Like

The track plays fine here through HDMI (did you try that?) and pretty much the same through the 3.5mm jack (given the crappy speakers I am testing with). The only thing I can think of is the voiceovers are somehow being played out of phase. Whether recorded in mono or stereo, they should be substantially the same on L and R. The clip you posted does have the channels in phase - the voiceover is probably mono:

If you record direct from the 3.5mm jack instead of a microphone and compare the channels it should be clear whether Vero is outputting in phase or not.

Vero has the ability to reverse the phase of one or both channels on the DAC. If you fire up alsamixer, you will see four controls for this. Lineout left N switch and Lineout right N switch should be set to LOLN_SEL_DACL_INV and LON_SEL_DACR_INV, the other two should be LOLP_SEL_DACL and LOLP_SEL_DACR.

I assume your tests on PC and medi8ter are using the same speakers so we can rule out the speakers being wired out of phase?

Update: I recorded the output direct from the 3.5mm jack playing your clip and it looks the same as the original clip except both channels are inverted (but in phase with each other). That shouldn’t be a problem unless you are playing sound through HDMI at the same time to another nearby set of speakers.

Another thought: in Settings->Player->Music there’s a button ‘Avoid clipping protection on ReplayGained files’. AFAIK that applies only to audio files and shouldn’t affect audio tracks on video.

1 Like

I would like to bring this issue back on the table… I have purchased new (good) active speakers, the Edifier S2000Pro active speakers (450€, so not a cheap computerspeaker). These speakers have an Toslink input. I tried to connect the Vero4K+ to these new speakers with an optical cable, set them to “monitor” mode to avoid any sound processing, and tried the same piece of movie with this setup. Sure, these speakers are different, but I still get the compressed sound from the Vero4K+. Almost the same as with the old speakers, maybe just a tad better. but surely far away from playing this clip on Kodi on the Win10 computer, or the old Medi8er mediaplayer.
And yes, they are in correct phase (it’s a proprietry cable connecting L & R, so they cannot be out of phase.

So, I’m still stuck with this issue on our Vero4K+ Any more suggestions?

PS: I tried both with “Avoid clipping protection on ReplayGained files” ON and OFF as suggested by @grahamh but no noticeable difference.

Tried something else: when a video is playing, pressing the “OK” button on the remote, has a settings icon in the lower right hand corner. Going into the “audio settings”, I tried to play with the “downmix Center mix level” (although it’s just a simple stereo soundtrack). Whichever setting I take, either the min level of -10dB or the highest +30dB, does not make any difference at all to what comes out of the speakers. Not really surprizing, as the video is simple 2ch audio.

I’m stumped. Since you are now using ToSLink, I recorded your clip from that output on Vero4k and compared it with a recording from Stereo Mix on my Win11 PC playing through the Windows Media Player. I can’t tell them apart. Can you try repeating what I’ve done ie recording direct rather than through the speakers?

By any chance is Kodi’s volume set lower than 100%?

No, no, this issue has nothing to do with volume… it is the lower dynamics compared to any other video playing device, using the same speakers, same microphone, same source file.
Obviously, the mike recordings have been “normalized” to be able to compare them. I chose a 2 second pauze in the speech (background music and live sound only), and amplified the whole recording to get the exact same dB level on the scale for that 2 seconds piece.

Will try to do, graham. I can do on the analog out, but I have no idea how I can record what comes out of the toslink port.

I have a USB soundcard with ToSLink in. Recording from analogue could be instructive though. I did the same comparison via analogue before and couldn’t get any difference in dynamics.

I should say, however I play your clip (HDMI, ToSLink, analogue) the balance between music and voice seems fine.