Dolby Atmos decode

I have some movies with only dobly atmos tracks. My AVR sadly doesn’t support this so I get no sound. Is it possible to let Kodi convert it ti DD or DTS on the fly to be able to decode it ?


If HD formats are not enabled, you will can pass it as LPCM.

Both HD formats are disabled right now and I still get the problem.
Shall I send a debug log ?

Logs would be useful. If your AVR supports HD audio (TrueHD or DTS-HD-MA) enable those and passthrough and it will just ignore the Atmos information and play surround sound.

There is an option to transcode to AC3 in the passthrough settings. To see the option the settings need to be set to expert. Also this will only work if the number of channels is set to 2, and passthrough is enabled.

My AVR supports both TrueHD or DTS-HD-MA but It doesn’t support HDR.
That is why I have to use the following weird setup

Vero4K -> hdmi -> OLED C7 -> hdmi ( arc ) -> AVR

This way I get use use my AVR to get 5.1 sound to the speakers but still have HDR picture.

Any ideas what should I change to be able to decode atmos ( or convert it on the fly ) but not losing HDR ?

Try wiring them up conventionally [vero->AVR->OLED] and
echo 1 | sudo tee /sys/class/amhdmitx/amhdmitx0/force_hdr

If it works put this line in /etc/rc.local
echo 1 > /sys/class/amhdmitx/amhdmitx0/force_hdr

Ok i get HDR now with that code despite the AVR doesn’t support it.
But now I don’t get ( the code doesn’t have to do anything with that ) any sound at all. Not even menu sounds.
I must have wired it wrong. Must try other HDMI ports I guess. Maybe it does have to do with the previous settings.

Thanks anyway :slight_smile:


This last no sound problem wasn’t kodi related it had to do with the avr’s hdmi port settings.
I can still provide the logs if you need but my original problem is solved thanks to your help.
It’s impressive how much support you give guys years after releasing vero :slight_smile:

1 Like