Dolby Atmos not working when Adjust Refresh Rate is enabled


I got my Vero 4K+ yesterday and plugged it in. Everything worked perfectly, but after some time (could be after reboot) Dolby Atmos sound failed to play correctly. Some sound was missing and the reciever didn’t indicate Atmos as it should otherwise.

After several trial and errors I noticed that if I disabled Adjust Refresh Rate and Syncronize playback to display I got Atmos working. In the same time I also noticed that Kodi is running in Windowed mode (not fullscreen) and cannot be changed to Fullscreen. If I use resolution 1920x1080@60Hz as recommended some parts of the screen is outside the TV. If I select 3840x2160@60Hz the interface looks correct. Could these two errors relate to each other?

The Vero 4K+ is connected to my reciever (Samsung HW-K960 Soundbar, to be able to get Dolby Atmos working it has to be like this). The HDMI-OUT on the soundbar is connected to the TV, a Samsung UE65KS7005.

Can someone please guide me in this? I added the log file from playing a Dolby test file with and without Adjust Refresh Rate and Syncronize to display enabled and disabled.

Thanks a lot!

Log-file when playing without and with Adjust Refresh Rate

It should work with Adjust Refresh Rate enabled, but you must turn off Syncronize Playback to use audio passthrough.

Windowed mode is displayed in settings but it’s really fullscreen (there is no windowed mode).

To get the GUI to just fill the screen, check your TV settings.

1 Like

Awesome! Thanks a lot! It works.

On the TV I had to change Picture size/Fit to screen from Auto to On. Not sure what Auto does, doesn’t seem to do it automatically at least :laughing: