Dolby Digital stopped working - fixed by Denon firmware update

Suddenly my Vero 4K stopped outputting Dolby Digital audio via my Denon 1300. I always had it set to output via HDMI and do the full passthrough for all formats and that worked with all my series and movies. Suddenly I only get sound from HD audio tracks, everything else is quiet and my receiver doesn’t pick up anything. It also keeps blinking the speaker output configuration when in the UI with no UI sounds coming up. I also tried different settings in System->Audio, rebooting it, switching to dev branch, nothing. Neither the Vero4K nor my Denon were updated prior to these issues. What did happen here?

Here is the log:


You seem to be running a pre-release version of OSMC, but your sources.list shows you are on the stable version.

Did you recently update on the staging repository, and if so, what were you trying to test? If nothing in particular, as always, we recommend staying with stable versions.

Can you try a reboot with AVR and TV on first and see if you can reproduce the issue with debug logging enabled?



Edit: I see you switched to the development branch after experiencing a problem. This is strange. Has the Denon received a firmware update recently?

I changed to the pre-release repo when I wanted to test the HDR fixes. I reverted to stable repo after that (maybe two weeks ago). Today was the first day I observed the problems with Dolby Digital content to my knowledge and I didn’t see an update of either the Vero or the Denon. Updates for the receiver had to be done manually anway. I only switched to the staging repository after those problems, hoping to be fixed there. Here is the log with debug logging enabled after a reboot (TV and AVR turned on) and playing a video with DD:

I obviously tried turning off and on everything but since my receiver offered me an update I just went for it and, well, it solved all the problems. So, sorry for bothering you but also thanks for the great support.

1 Like

Looks like Denon are making some improvements.

Thanks for letting us know that a firmware update resolved your issues.
As always, give us a shout if there are things we can do on our side