I’m trying to get the Display-O-Tron 3000 to work with OSMC but for some reason I cant. I have everything install (I think) but i keep running into an error. I know its something to do with spidev but i don’t know what. Please help, if you need more info just say.

get their official scripts and remove the is raspbian parts hate it when pimoroni does that in thier scripts second time someone asked for support for thier crap here and i looked at the code and there is nothing rapsbian specific in the script basically it can work with a simple debian installation

this crap

IS_RASPBIAN=`cat /etc/*-release | grep Raspbian`

if [[ "" == $IS_RASPBIAN ]]; then
	warning "Warning!"
	echo "Please only run this script on Raspbian on your Raspberry Pi"
	exit 1;

I done all that. It all installed apart for st7036 ( installed that separately) but still not working

I keep getting this error

Have you tried enabling SPI support in MyOSMC>PiConfig?

Yep, but still nothing

No offense but, if you didn’t know, after enabling SPI, a reboot would be required before it would become active.

Yeah, I done that and a modprobe thing but still nothing

spi enabled in config.txt ?

I added


at the end

but still nothing. I might just give up