Dpkg-split error while updating


I am having a similar problem, with the installer telling me to report the error on the forum. Neither the GUI nor the apt-get way haver worked so far, with several reboots in the process (to see if it had any effect).

The log is in https://paste.osmc.tv/cefiguxoju if it is any help.

Thank you very much.

You’re getting an error message that suggests a file corruption:

dpkg-split: error while loading shared libraries: dpkg-split: unsupported version 62047 of Verneed record

Please SSH to the Pi and run the command md5sum /usr/bin/dpkg-split It should be fe03e007d6b92690ca5c38c270820ed8.

Edit: I’ve also split this off into a new thread, since your problem differs from the OP’s

If it’s never worked for you I recommend a new install on a clean SD card. Also check your power supply

The md5 is 05697be20d27c22c873f0300818d70dd so the package seems indeed to be corrupt. Or maybe a different version?

How can I fix this?

Thank you for your quick help!

Fixing it might require a full reinstall since file corruptions often involve more than one file. But for now we can try to fix only dpkg-split.

The “obvious” thing to try is to reinstall the dpkg package but that might not work if it needs to run dpkg-split. :wink: But we can give it a try:

sudo apt-get update && sudo apt-get install --reinstall dpkg

If that doesn’t work, Plan B involves downloading the package and extracting the file:

cd /tmp
apt-get download dpkg
dpkg -x dpkg_1.17.27_armhf.deb dpkg-files
sudo cp /tmp/dpkg-files/usr/bin/dpkg-split /usr/bin

Thanks a lot for your help.

The second method seems to be working. The first one, as you predicted, ended in the same attorney as the upgrade.

Thanks again!

Good to hear. If you haven’t done so already, you can try rerunning the dist-upgrade.

I am on it, although it is taking some time as usual.