Driver for R820T2 based USB DVB-T

Hi everyone,
I have one of these cheap chinese dvb sticks with the RTL2832 and R820T2 tuner chip (as read off the chip itself)
The driver supplied with the kernel do recognise the device and it shows up in tvheadend.

However, the R820T2 must have different capabilities to the R820T (which the kernel driver supports based on other forum post.

I have searched this forum, linux tv, and google for anything, but havent found anything.
I have used this dvb stick with PiAware and succesfully received ADS-B signals, so I don’t think it is a hardware fault.

Raspberry Pi 2B
Hifiberry Amp+ working OK.
Tried with OSMC (4.4.13-5) and Raspbian Jessie (4.4.15-v7+)

Also tried on a amd64 machine with Debian - same result

relevant dmesg | grep usb shows
[ 11.026985] usb 1-1.4.6: New USB device found, idVendor=0bda, idProduct=2838
[ 11.027011] usb 1-1.4.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 11.135877] usb 1-1.4.6: dvb_usb_v2: found a ‘Realtek RTL2832U reference design’ in warm state
[ 11.192286] usb 1-1.4.6: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[ 11.243826] usb 1-1.4.6: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))…
[ 11.370617] usb 1-1.4.6: dvb_usb_v2: ‘Realtek RTL2832U reference design’ successfully initialized and connected
[ 11.370979] usbcore: registered new interface driver dvb_usb_rtl28xxu
[ 19.966261] usb 1-1.4.6: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000…862000000)

some pictures of the device: