Droibox Nano OSMC support?


#1

Hi, quick question…
I have a Droibox Nano (from JustStop Ltd), which is absolute pure junk. I crashes religiously, and i’m no fan of the Android 7.1 as a media OS that its running on.

Is there any chance to run OSMC on this box? Has anyone tried it?

TIA,

Jez


#2

OSMC (in its current version) is limited to the Raspberry and Vero Family at the time of writing this.


#3

Hey Fzinken,
Thx for reply. I’ll hack around with this box when i get some time.

cheers


#4

LibreElec is what you are looking for for this box. It is a JEOS (Just Enough Operating System) for running Kodi.
I don’t want to post a link to specific site but if you google “install libreelec on android box” the top result should be a guide from March this year and it seems fairly comprehensive.
I actually have the same box (picked it up for £15 from Amazon) and have been considering trying it myself but just haven’t had the time or indeed the need. I just use OSMC and Raspberry Pis.


#5

Just to follow this up…
I actually tried it this evening and it was relatively straightforward actually installing LibreElec (Once I used an SD card that was working…).
It seems to run very well and relatively quickly on the Nano, given it only has 1GB of RAM.
Only major issue I had was that I had to create a custom remote.conf file in order to use the IR remote that came with the box. Bit of a pain and a slog but all the major functions are now working.
Was just in a tinkering mood and OP’s post made me have a go.
Lots learned in the process. More to go.


#6

Nice work CC, and thanks for the update on this.
I had seen LibreElec on initial investigations yesterday, but focused efforts on new fw for the box (based on it being t95n/s905w hardware). No joy so far, so will switch towards LE.

…should at least keep me occupied till my V4k finally lands, hehe!!

Cheers


#7

CC, quick update… I got this running with LibreElec, and it runs sweeeeet!
Had to route around for a correct bootloader (in my case “gxl_p212_1g_nand.dtb”, as i kept getting stuck on android screen), but once in took just moments to flash.

Kudos!

Ps, also came across Alex@ELEC on github whose doing some good work with coreElec. Will try that sometime also.


#8

Nice one. It seems to run very well on my box too. Pretty zippy for what it is.
Hopefully I’ll find a use for it!
Edited to add: I also got Kodi installed on a SteamLink a few weeks ago. It runs terribly but it was an interesting experiment!