Dropped frames caused by subtitle rendering

I have a same problem described in this LibreElec forum:

Play any 23.976 fps movie with external subtitles and you’ll see dropped frames the moment first subs appear on the screen. Sometimes it’s very visible and sometimes bearly visible, even playing the same file. If you disable subtitle problem is gone, and if you disable amlogic hardware decoding you don’t have dropped frames. Subtitle are srt. Someone mentioned in forum above that only UTF8 are affected. I use croatian subtitle. Other settings are almost default.Only Adjust framerate On, sync to Display off (tried with ON and problem is same). Also tried every possible combination with refresh rate, font size, font type, code page, etc. Only solution is to turn off subtitle or hardware decoding. I can provide a link to cloud with movie + subtitle with apparent case.

That should only affect S912, not Vero 4K.
It’s fixed in R7P0 but that brings other issues

Can you reproduce this with a Kodi v18 build?

I did not tried v18 yet, is it in beta phase still?
This is a link to one movie with subtitle problem. cca 3:51min and 4.00min are problematic parts.
https://drive.google.com/open?id=1Yiz0sXXbz_8aDOcA4U5l_-8hclvwsRpm

To get a better understanding of the problem you are experiencing it might be useful to get some debug logs from you. If you need instructions as to how logs are provided see here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Just try and run the problematic scenes while logging and upload the logs for us to see what we might be wrong…

1 Like

Thank you for your help. I will upload the log, as soon as I get home. I am away right now.

Kind Regards
damir

This is a log
URL:https://paste.osmc.tv/ciyobuwija

http://paste.osmc.io/ozejivicot.coffee
Mediainfo of movie. Played from USB or NFS (fstab) share same thing
Tried video cashing (advancedsettings.xml) with bigger values also.

This is a log with another movie, stutter is on first seconds (where subtitle start)
https://paste.osmc.tv/ijekunaloy
Here is also a small 10 seconds clip from movie (4MB) where subtitle start)

It is played from USB stick now, and when I disable hardware acceleration -amcodec or subtitle the stutter is gone. It is not there always, you have to play sometimes a few times to reproduce it.
I tried on other TV with other HDMI cable and same thing.

Could you give the workaround explained in the following Kodi forum thread a try (disabling DR in advanced settings)?: Kodi's Dirty Regions - ARM GPU Tech - improving Kodi rendering performance
It’s merely an idea, but who knows :man_shrugging:t2:

Let us know, if it solves the issue.

2 Likes

Thanks, I will try it when I get home.

Just to avoid confusion… The path you’ll need in the Kodi wiki article is /home/osmc/.kodi/userdata for your OSMC device. If you need any help, just give us a ping :+1:t2:

1 Like

Same path like video cash changing in advancedsettings.xml, thanks

1 Like

I tried disabling DR in advanced settings, but nothing changed. Only workaround for now that help to have subtitles and stutter free playback is to disable hardware acceleration -amcodec.

We can fix it, but not until mid to end of May unfortunately.

Sam

1 Like

That is a great news, whenever will be fixed.

We’ve taken a stab at this, but it will still be a few weeks before we include any improvements in a stable update.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam

Thanky you for your help and assistance.
I tried this update, but there is no progress.

Regards
Damir

Sorry to hear that.

Can you post some logs so we can verify you did upgrade?

Sam

Here is a log with update and played problematic scene.
https://paste.osmc.tv/fugonilevo

I don’t think you updated properly. The new driver is not stable enough however so we have to revert it for now

Sam