Dropped frames caused by subtitle rendering

Well the dropped frames issue on subtitles is new since the Kodi 18 update.

Anyway, I try out your suggestions… How to I increase render thread priority? Advanced settings I suppose?

We’ve seen the subtitle issue on v17 as well… Mostly with PGS subtitles.

Never noticed it before but I only use SRT subtitles. I am pretty sure there was no frame drop with SRT in Kodi 17, at least for me.

Was hopeful the issue was fixed in Leia, obviously not…

Same deal on Kodi 18 as before. Avatar is a good test because it uses 1920x1080 PGS subtitles for the forced ones and some scenes where they are used have nice slow and steady movement where you can see it easily. The testclip I linked September '18 still demonstrates the problem in Leia. Basically there has been no improvement in Kodi 18 compared to Kodi 17 as far as I can tell in regards to playback on the Vero.

I don’t think VideoPlayer moved far enough with v18 as expected. So some of the old Kodi limitations still exist.

I’ll try and work around them

I will do some testing tomorrow with „dirty regions“ in advancedsettings, While I was using the libreelec box until the sync issue was fixed, I did alot of testing on other small issues and had some promising result with one particular setting. So I am hoping to get the same effect on the Vero 4k.

I’ve never seen this issue before until the other night when I was watching the first Avengers movie with my children.
There were a couple dropped frames right before the first subtitles were displayed.
That brought me here where I found this thread.
Interesting read.
Unfortunately I was unable to duplicate the issue.
Every attempt after the initial veiwing played smoothly, even with statistics on screen.

I watch a ton of 1080p Remux, Web-DL and encodes mostly with muxed in srt subtitles and never had this issue. Would be interesting to know what triggers it. Maybe only PGS maybe 4k ? Or some sort of combination of it

PGS subtitles, no matter which resolution. But it seems to be a lot more severe with 4K.

1 Like

Whats interesting is that i don’t have this issue with my Pi 3 when iam using OMX Player instead of MMAL. I don’t understand why the old OMX Player has no problems with it but MMAL does?

This topic is related to the Vero rather than the Pi. MMAL uses more resources, so is to be expected.

Yes but the RP 3 was mentioned above thats why i tested it (Avatar with PGS Subs) and was surprised that OMX didnt stutter but MMAL did.

The issue still persists, that is frame drops the first time a subtitle is displayed (SRT @ Vero 4k). I kind of accepted that and it doesn‘t bother me much anymore… though if it disappears sometime in the future, that would be nice too :wink:

1 Like

I’m looking in to this but was using PGS as an initial test


Sometimes when there is nothing spoken for a longer time, a nee frame drop may occur as well when the next subtitle appears… seems like the stuff rendering the subtitle offloads after a certain amount of time as well.

Could you add a feature (with on/off switch in settings) that always loads the module for subtitles and always keeps it active? The drops for SRT seem to be purely a result of Kodi loading it during playback (and possibly after longer time of no subs during playback). I think you mentioned something like that before.

It doesn’t really work like that.


I experience this issue since 2017 when I switched from pi to vero 4k.

Now I have a vero 4k and a vero 4k + and both have frame drops with srt subtitles. Playing 1080p or 4k videos, it happens all the time


This should be solved in 4.9, where we have updated the GPU driver.


I’m having some easily-repeatable massive frame drops in anime with subtitles on, e.g. Attack on Titan on my 4K+. It’s hilariously bad at times, especially during the intro for the show with the fan subs on. As soon as I turn the subs off the frame rate is silky smooth. The files are HEVC MKV (ASS-type subs). No issue playing these on my phone, iPad etc.

Is this issue still being worked on?

Can you share a sample of said file?