DTS/AC3 passthrough not working


I have a general issue with passthrough of AC3 and DTS after (one of) the latest update(s). It totally worked before (when I bought my V4K), but now, my Onkyo TX-NR3007 only detects “Mulitchannel” but no DTS/AC3. I did not change any of the settings in Kodi.

Is this behavior caused by your attempts to solve the DTS-HD-HRA issues?

Please “fix it back” in the next update, a network player without basic DTS/AC3 passthrough is no fun :cry:

I would suggest you make a dedicated topic about your issue and provide debug logs as this will probably be asked.

This is not expected. You are the only one to report it so we need a bit more information.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

This happened to me as well, I downloaded the update when I got home from work today, and DTS/AC3 passthrough stopped working. I had to disable passthrough to get sound back.

I’ll submit a log through MyOSMC.


Thanks for that. You are playing E-AC3 here (DD+). Can you confirm if plain DD is being passed through?

Update: just noticed you are running the unstable (stretch-devel) version of OSMC. Can you confirm E-AC3 was working 2-3 days ago (kernel version 71 which you installed 21/3/18)?

Update2: You seem to be upscaling a 1080p clip to 4k. Does the audio work properly without upscaling?


many thanks for splitting my answer into a new thread and sorry, I wasn’t able to answer any sooner, I was pretty busy.

As a matter of fact, I just tested all variants of HD sound that I have material of (DTS, DD, D-THD and DTS-HD-MA). My Onkyo NR-TX3000 did not play a single in the dedicated format.

Atttached please find my logs:


I tested of four files (Blade Runner 2049.mkv, Dolby True HD; The Blacklist S05E11 Abraham Stern.mkv, E-AC3; The World is not Enough.mkv, DTS and The Wolf Of Wall Street.mkv DTS-MA core)

None of which werde detected by my AVR. Please help.

Thank you!


I’m going to have to get home to test the upscaling and plain DD aspects of your post, but I can confirm that I had zero issues with the passthrough on the kernel 2-3 days ago. It was only upon updating last night that I ran into these issues.

Edit: Interestingly, the Atmos track on Darkest Hour passed through just fine when I tested it last night.

Edit 2: I’m not sure what the upscaling is from. Do I have a setting activated in Kodi that’s forcing the box to upscale the video? I know I have the general menu set at 4K because it displays much better on my LG E6, but I didn’t think I had any video upscaling set on the Vero.



You have activated

Settings -> Player -> Sync Playback to Display

With that setting not any pass through is working; deactivate this flag.

If I’m not mistaken, this happens one second after you start the clip:

Mar 26 22:53:05 XBMC kernel: hdmitx: system: already init VIC = 0 Now VIC = 98

VIC=98 means 4k. I don’t know whether setting the GUI to 4k is suppose to do this. I thought not.

I’ll double check when I get home, but if my memory serves the sound wasn’t affected by any upscaling. It would, however, explain why my videos recently started to “pop” after a few seconds, for lack of a better term. Probably implementing upscaling at that point.

Thanks for the help! I’ll try to put up more logs this evening.

Plain DD appears to be working fine, here’s the log:


DD+ still not working as passthrough though.

Please update your kernel once more.

Newest kernel appears to have fixed my issues.

Thanks, Sam!


Can this help with my issues with DD(+) as well?

It should do. Please make sure you are on the latest update.

Oh boy, this is embarrassing :blush:

Sorry for causing you the effort, I’ll try when I come home!

Thank you for your help


Haha, don’t ask me how long I searched when this happened to me the first time … :joy:

Happened to me too, it’s completely unclear that this would be causing issues if you didn’t know about it.

Not completely unexpected but as often you’ve to read the fine print … :wink:

I think it’s a default setting though, which I at least didn’t think to adjust when setting up my sound.

1 Like