Duplicate entries in db from smb share

Could not find an answer elsewhere. Searched for “smb”.

Using Raspberry Pi 2 B. Had my media files on hdd connected to
Pi via powered usb hub. Everything worked fine. Then plugged hdd into router. Removed all old sources. Added new sources. Got duplicate entries on all TV shows and music db but not on movies. Deleted DBs in userdata and rescanned. Same result. Re-installed osmc. Same result. Problem not showstopper but would welcome a fix. I’ve also tried cleaning library with no result. In duplicate entries, only one entry links to actual files. Will take a look at db entries when I get a minute.
I’m a fairly vanilla user but so far, osmc looks good! Keep up the good work.

Look at a debug log that contains the scraping of the source. This should indicate what is being counted twice? Also, I would put my eyes on sources.xml to make sure everything is as it should be there.

Are there any samples in the folder?
I’ve seen that result in duplicate entries in the database for me. Only solution was to remove the samples. After that doing a Cleaning of the library, but in some cases I needed to remove the source, do a cleaning of the library and then adding the source and doing a new scrape.

Renesdk, no samples in folder. Also removed Apple hidden files. No joy.

Haven’t had a chance to look at DB yet, but here’s another clue, hopefully.
My source is called tv.
If I start at top level VIDEOS - Files - tv - episode names only appear once
If I start at top level TV SHOWS then every episode name appears twice!
Will follow up if I get more.

Can’t seem to access databases. Is SQLite the db system?

unless you’ve setup mysql, yes

Getting “sqlite3: command not found”. What am I doing wrong?

Ok, so I tried installing sqlite3 and got:

E: unable to locate package sqlite3

Any help appreciated.

I had this issue as well, years ago. I found the issue in my sources.xml file. http://kodi.wiki/view/Sources.xml

Look for duplicates there, or (back it up and) delete it and try adding the sources again.

1 Like

I am new to OSMC & installed it on a RPi2. I can’t seem to install rsync & get “E: Unable to locate package rsync”. I tried to follow the link above but could not find file sources.xml. Any help would be appreciated. Thanks

to install rsync, it should be as easy as:

sudo apt-get update
sudo apt-get install rsync


sources.xml is in /home/osmc/.kodi/userdata
if your user is named osmc (what it probably is), but you can also access it this way: ~/.kodi/userdata

Edit: excuse me: I didn’t see this topic was 7 months old.