Duration display on menu view

Hello. There was an update last year, after which a feature I found very useful seemed to disappear.

My movies folder was always displayed like this (please excuse the use of photos, I have no idea how/if I can take screenshots on my TV):

Previously there was a setting that allowed for the duration of a movie to be displayed in the bottom left of this view. This was super useful to me, as I often select a movie based on how long it is and how much time I have.

I believe that there are other view options that do include duration in the display, but I much prefer this option. I also know that I can go into the movie folders one by one to check the duration, but that is inefficient and slow.

Does that duration-display option still exist on this view? If so, where can I find the setting to switch it on?

I’m using OSMC on a Pi4.


The duration as well as media flags will be shown in all media views by default… Do check this skin setting: The OSMC Skin

Here’s that screen on my setup.

To be clear, OSMC displays the duration when I enter the folder of a specific movie. I think that’s what the setting you linked to changes.

I am looking to restore the display of duration from the library view in my original post, so I can see the durations as I scan through the library.

It doesn’t display it by default any more - I’ve done a clean install to try this and it’s not displayed.


looking at your screenshot I see ‘2-movies’ below the ‘Movie’ menu title.
Is this an actual OSMC version and the OSMC skin or some other configuration?

Regarding the missing movie tags: These are not displayed for movie sets. If this was shown before, you haven’t activated the movie set feature in the past, so, please check at settings->media->videos whether the flags

Show movie sets
Include sets containing a single movie
show videos with mutliple versions as a folder

are disabled.

Thanks for your reply.

‘2-movies’ is just the name of the folder on my NAS which is being browsed in that photo. If I change into a different folder, that text changes to the new folder name.

I don’t think I’m using any special skin modifications, only the settings that come with the installation.

I went into those settings you mentioned. They were both unchecked. Checking both of them, or either of them one at a time, makes no difference. Duration is still not shown in the library view.

As far as I remember (my memory is not clear) this used to be a settings option. The duration was shown on my OSMC in the bottom left as you scrolled through the library. There was a fairly major update some time last year. When I rebooted, the durations had disappeared from bottom left, and I haven’t found any way of restoring it.

I’ve checked on my setups here (up-to-date, latest stable version) and any option for the media flags works just fine: the duration is always shown when expected. I’m not sure what might be going on on your system :thinking:

Do you feel confident to SSH into your device?

Hi, thanks for the reply.

Yes, I have ssh set up on it. That’s how I do updates as the built-in update function has never worked on any of my osmc Pis.

I can ssh in but would need specific details of what to look for.

Thanks again.

I think this is the crux of your issue. It is showing the name of the containing folder because you are browsing in file mode and not library mode. In file mode this would be expected behavior when a folder is selected as, unlike in library browsing, it shows folders, and folders are not media. When the option is enabled it will show some artwork and metadata, but not everything. Perhaps you have your movie main menu item configured to browse videos>files instead of videos>movies in your skins custom main menu items settings?


Thanks for your reply, I really appreciate everyone’s attempt to help.

I think that would make sense but not sure if it would explain why a software update led to the movie durations no longer being displayed immediately afterwards.

In any case, the top level folder in my movies section is indeed set to browse movies, and always has been.

What you were used to did probably change with one of our last major updates because visibility conditions changed in our skin due to some rework of the media flags. Your use case is not the usual, so it went unnoticed.

I’ll check whether we can mitigate this with our new v21 skin. :+1:t2:

Sorry for not being completely clear. What you are showing with that screenshot is your scraper settings and that isn’t the setting I was referring to. In settings>interface>skin>configure skin>general>customize main menu> there is options for what exactly you are navigating into when you click on the menu items in the home screen.

1 Like