Dut-IPTV addons keep buffering (Ziggo, KPN)

Since a couple of weeks I’m experiencing issues with playback of Live TV on both Ziggo Go and KPN. Ziggo Go was working perfectly before, but KPN has been problematic for a longer period, resulting in me using Ziggo Go.

For both of these addons from (dut-iptv · GitHub) the LiveTV streams just constantly keep buffering. I’m using the latest version for both and tried reinstalling and resetting them. The stream does start initially but it immediately starts buffering and will not stop, making it unwatchable.

I tried the addons on Kodi on Windows, and both work there without issues. Nothing is wrong with my connection since I’m on high speed fiber and every other streaming app/addon works without issue. I’ve also tried re-adding the repo and reinstalling + resetting the addon, but still the same issue.
What could be the issue here?

Here is my kodi log: http://paste.osmc.tv/udowacusac

The device I’m using is Vero 4k+ on Kodi 19 (March '22 update)

2022-03-15 09:17:44.172 T:3150 DEBUG : CVideoPlayerVideo - video decoder returned error

A sample of the video would be useful.

Thanks for the reply. Here’s a video of the issue: 2022-03-15-
This video is from the KPN iTV app, but it’s basically exactly the same issue for the Ziggo app. Except for the Ziggo app playing the livestream slightly longer before it starts buffering again (like 1 second).

Sorry – I mean can you provide a sample video of the actual file you can’t play?

Sorry, it’s not a video but it’s a livestream of different TV channels from the earlier mentioned repository. KPN and Ziggo are local ISPs that have apps for smart tvs as well and these addons were made where you have to login with your credentials to watch livestreams.

Okay. It could be a bit tricky without getting access to one of the streams.

We have a new video stack with some IPTV improvements. I’ve added you to the conversation.

Okay so I understand correctly; I have to boot from the image file on USB? And then I’m on a fresh and separate osmc from which I have to start the livestream in the addon? So everytime I want to use the addon I need to switch from the ‘normal’ image to the one on the USB?

It sounds like the actual widevine problem. You need to downgrade your widevine for example using the beta of this inputstream helper:



Thanks, that looks like the exact same problem indeed. Could you maybe tell me specifically what I have to do? Google translate isn’t 100% clear to me. Replace my inputstreamhelper script with the one from that post, and then? I’m not seeing ‘install from specific source’ in the inputstreamhelper settings.

Then you have to start inputstreamhelper and just reinstall widevine.
If that doesn’t work install an older version under ‚debug‘ → “install from specific source”
I‘m not at home so i can‘t look for the specific text.
Hope that helps.

I replaced inputstreamhelper with the new linked one and went into the inputstreamhelper settings and selecter reinstall Widevine, but the problem still persists.

I don’t see the option ‘debug’, where can I find that?