DVB subtitles displayed in LIVE TV

Hello everyone, I’d like to ask for an advice. I just recently figured out how to enable DVB-T2 on offical dongle on VERO4. In Czech Rep. we moved to DVB-T2 and I spend a lot of time figuring out how to do this - at the end it was just one parameter in TVHeadend (in muxes tab you have to set PLP ID for each mux from -1 to 0). Now, everything works, but I have DVB subtitles in every channel and I can’t figure out how to turn them off. In TVHeadend? in OSMC? Thanks

You should be able to disable them under audio settings. The appearance of this option depends on the skin that you are using


Thanks for your fast response Sam. Unfortunatelly I was not able to find this setting. I’m using the default osmc skin. I’ve searched in Settings->Audio and also under audio icon when playing TV

@darwindesign, thanks, but there is no such icon when watching live TV, you screenshot seems to be from local file watching.

It was as I don’t have live TV setup on any of my boxes. I assumed it was the same either way. Apparently not, sorry.

If you have a USB keyboard at hand, connect it to the OSMc device, start Live TV of the channel you want to change and press “t”.

I’ve checked our skin’s code and there’s indeed a visibility condition which prevents the icon to be shown during live TV playback… Honestly, I don’t know why. I’m being told other skins show the icon just fine. For the next update, I’ll make the icon show up. :+1:t2:

1 Like

:+1: that is great news, I’ll wait for that and try the keyboard trick in the meantime

1 Like