DVB-T muxes scan fail on RaspiB / OSMC with i2c errors

hi there!

first of all thanks for a great piece of software.

recently I have started to experiment with a new USB DVB-T stick to get live TV in OSMC on RaspiB 1st gen. the stick is NooElec NESDR Mini 2. the problem is the TVHeadend server in OSMC is not able to tune any channels in any of the provided muxes, which worked fine in Windows on a different computer. the stick is recognized as RTL2832. I have checked the dmesg messages, which show many errors reading from i2c. I have not seen this reported previously.

> osmc@osmc:~$ dmesg | grep -E "rtl|dvb"
> [  110.298123] usb 1-1.2.1.4: dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
> [  110.353957] usb 1-1.2.1.4: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
> [  110.568007] rtl2832 2-0010: Realtek RTL2832 successfully attached
> [  110.757296] usb 1-1.2.1.4: dvb_usb_v2: schedule remote query interval to 200 msecs
> [  110.771025] usb 1-1.2.1.4: dvb_usb_v2: 'Realtek RTL2832U reference design' successfully initialized and connected
> [  110.967913] input: MCE IR Keyboard/Mouse (dvb_usb_rtl28xxu) as /devices/virtual/input/input1
> [  110.981330] rc rc0: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 0
> [  111.020510] rtl2832 2-0010: i2c reg read failed -32
> [  111.023396] rtl2832 2-0010: i2c reg read failed -32
> [  111.026895] rtl2832 2-0010: i2c reg read failed -32
> [  111.035695] rtl2832 2-0010: i2c reg read failed -32
> [  111.084519] rtl2832 2-0010: i2c reg read failed -32
> [  111.087135] rtl2832 2-0010: i2c reg read failed -32
> [  111.098726] rtl2832 2-0010: i2c reg read failed -32
> ...

> osmc@osmc:~$ lsusb
> Bus 001 Device 005: ID 050d:935a Belkin Components F6D4050 N150 Enhanced Wireless Network Adapter v1000 [Ralink RT3070]
> Bus 001 Device 010: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
> Bus 001 Device 009: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
> Bus 001 Device 008: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
> Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
> Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> osmc@osmc:~$ 

> osmc@osmc:~$ uname -a
> Linux osmc 4.1.3-2-osmc #1 PREEMPT Tue Aug 4 13:29:12 UTC 2015 armv6l GNU/Linux

two images from TVHeadend web interface:

what could be the problem? what should I try?

thank you very much for your time and patience…

orr721

I believe this is an upstream issue with rtl2832xx devices

Sam

eh, ok, time to move on then…

thanks anyway.

It should be resolved in the next update which is due shortly

Sam

I’m having the same issue with the same module, the scans all fail:

This is what dmesg has to say about the dongle:

[    2.378424] usb 1-1.4: new high-speed USB device number 6 using dwc_otg
[    2.490295] usb 1-1.4: New USB device found, idVendor=0bda, idProduct=2838
[    2.490320] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.490336] usb 1-1.4: Product: RTL2838UHIDIR
[    2.490352] usb 1-1.4: Manufacturer: Realtek
[    2.490368] usb 1-1.4: SerialNumber: 00000001

And then there are lots of:

[ 1118.455435] rtl2832 3-0010: i2c reg read failed -32
[ 1118.455484] r820t 4-001a: r820t_read: i2c rd failed=-32 reg=00 len=4: f9 30 ce ff
[ 1118.464278] rtl2832 3-0010: i2c reg read failed -32
[ 1119.458067] rtl2832 3-0010: i2c reg read failed -32
[ 1119.458115] r820t 4-001a: r820t_read: i2c rd failed=-32 reg=00 len=4: f9 30 ce ff
[ 1119.464416] rtl2832 3-0010: i2c reg read failed -32

It’s a real shame. I’ve read that it has something to do with the kernel, can somebody help me out? If more information is required I can provide. This stick has been working before, I’ve read, hence why I bought it.

Hi,

I have the same fault, it was working on my old raspbmc build fine so I know the hardwares ok. I get the exact same failure as described above.

Does anyone have any update on this - I think from what I understand something upstreams broken but Im not sure what or how or where to even google!

Thanks!

David.

see DVB-T dongle not working after 2015-08-03 update - #24 by nirvana80 for a solution

Looks like it will be solved in kernel 4.3

see https://bugzilla.kernel.org/show_bug.cgi?id=103391

@sam Nazarko do you know when this will likely to land in osmc?

I re-based the OSMC kernel for Raspberry Pi on to 4.3 this morning a few moments ago:

It will be included in OSMC’s November update.

Sam

1 Like

Tried today with the new kernel and i am still experiencing errors :frowning: so this did not solve the problem

Hi everybody.

I’ve experienced same problem.
After last update today it’s working fine :smiley:
It seems like that new kernel solved that issue.

I would recommend to disable idle scanning in the frontend as when disabling it i do not see this error anymore.
Maybe my problem could be due to the stick itself. I have just been chatting to people on tvheadend irc and it looks like there is patches on the way for my dongle that have just landed today.

https://patchwork.linuxtv.org/project/linux-media/list/