DVD playback .... really?

Hi there!

Long-time OpenElec user finally jumped to OSMC and have been very happy with it so far, especially the ease of installation and overall stability :slight_smile: Great work!

But now I have troubles with mpeg-2 playback, which I didnt in OpenElec.
Mainly DVD’s, both as folders or ISO files, but also mpeg-2 as 1080i .ts streams.
Last time I had troubles with the DVD’s, I could set them up to be played via DVDPlayer without hardware acceleration. Everything worked, menus also.
But that was Gotham and Helix, but after Isengard 15.2, this is not an option anymore, it seems?
And now I cant find neither the cause or the solution.

I tried switching off MMAL hardware decoding under Settings, but that did nothing.

Can anyone help out?

Logs dude :smiley:

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

I’m assuming you don’t have an mpeg2 codec license then ?

For standard definition DVD’s a Pi 2 should in theory be able to software decode it, although I’m not sure how well Isengard does this. For a Pi 1 you are pushing your luck and it probably won’t work.

Neither Pi 1 or Pi 2 are capable of software decoding 1080i.ts streams - you’ll definitely need the mpeg2 codec license for that. (Did you forget to enter it, if you do have one ?)

To force software decoding in Isengard you turn off both mmal and omxplayer. Note that if you don’t have a codec license (or it is something that can’t be hardware decoded) it will automatically drop back to dvdplayer using software decoding anyway - there is no real need to manually force this in Isengard.

More information including debug logs is really needed to get any further here.

Hmmm … It gets weirder now, because I actually do have the MPEG-2 license, entered and all … on an RPi 2.
I tried disabling both omxplayer and mmal acceleration, but that only gave me straight audio playback without video.
Before, I was running Helix on an RPi 1 Model B, and it all just worked. MPEG-2 1080i streams, dvd folders, ISOs, the lot :confused:
I’ll try and get a debug log with this stuff and maybe you guys can extract something from that …
Thanks so far! :slight_smile:

Ok, here’s a link to a log file.

http://xbmclogs.com/p0ojv5q8o

Here I tried watching a dvd (Matrix Bonus dvd) via the Video Extras add-on.
The menu starts with audio, but video is lagging hard and everything freezes, when I select a menu item. No problem stopping playback, however, and KODI doesnt crash or anything.

Can anyone make anything of this?

Thanx in advance :slight_smile:

22:45:40 14.415527 T:1958625840 NOTICE: ARM mem: 753MB GPU mem: 255MB MPG2:0 WVC1:0

Your mpeg2 and wvc1 codecs are not installed properly.

Were they purchased with the serial number for THIS pi?

I don’t get this … But that was it.
Thank you so much. Cant explain it. The codes really were correctly entered.
I entered them again (first deliberately in the wrong way, including the prefix, just to try it, and then again just like they were in the first place) and suddenly they were enabled, which they apparently never were.

Now dvd menus are working and playback too… BUT!

Another issue I’m getting here with the dvd folders and ISOs is, that at the beginning of playback from a new place, be it the very start or a chapter f.e., the playback speed is VERY unstable, audio bouncing up and down in pitch until finally settling after 5-10 seconds.
Anybody tried this? Or maybe thats just another thread …