DVD subtitles


when I play a DVD image (ISO) on my Vero 4k+, almost always subtitles are enabled. I have to disable them manually every time. The option “save as default” doesn’t seem to be doing anything.

This has been the case since the “big update” to Kodi v20. Before, it used to be fine (default was “saveable”).

Is there something I can do?


Does this occur with videos or only DVDs?

It’s possible your library is corrupted and this setting is not persisting.

This is just with ISOs.

I’ll try to reset the DB.


I don’t think resetting you db is going to make a difference. Can you post a log set so we can see what your preferences look like.