Easiest way to get list of "in progress" movies?

I would like to have an easy way to see my “in progress” movies. I want to get the same set I see if I manually go into “Movies” and select filter >> in progress >> yes

I tried setting up the skin widget to Recent, but this shows newly added as well as in progress.

I then created a new menu in the skin, and am trying to set a custom action. But I do not know if there is actually an action that I can specify for filtering? I do not see anything here: http://kodi.wiki/view/Opening_Windows_and_Dialogs Perhaps I can set it to RunScript, and have something in there?

Just created the smart playlist in this link and call it from the menu item

In Progress Movies Smart Playlist

@creemyv thanks for the idea. I had partial success, but then a big fail :worried:

I defined a new playlist per your suggestion and saved it in the playlist folder as “inprogressmovies.xsp”. I then specified a custom action from my new menu item to call this playlist: ActivateWindow(Videos, special://videoplaylists/In progress movies/). This worked fine, except that it only navigated to the playlist, it did not actually open it - so I needed to click the playlist title to actually get it to display the movies.

Trying to get it to actually open the playlist, I then changed the action to: ActivateWindow(Videos, special://videoplaylists/inprogressmovies.xsp). But then the whole OSMC front menu went away!

So now my homescreen is blank. I see the date / time at the top, but nothing else. I tried a reboot, but same problem. Obviously, with no menu items, I cannot go back into Settings and reverse the ActivateWindow command. Do you know how I can fix this through SSH?


Would have worked, you didn’t add the return command so Kodi won’t know which Window to go to after processing the first Window request. This is probably why you ended up with the blank screen.

Sorry, I have very little experience with the osmc skin but there must be a way to reset it.

Skipped the part about SSH. In the “/home/osmc/.kodi/userdata/” deleting guisettings.xml and restarting will work.

1 Like

No luck with this. Same problem on reboot.

I ended up restoring an SD image I had taken before. Then I re-did the custom menu item (adding “return” this time around), and it worked fine.

ActivateWindow(Videos, special://videoplaylists/inprogressmovies.xsp, return)

Thanks for your help!