Edimax EW-7811UAC doesn't see any 5GHz network

Hi there!

I bought an Edimax EW-7811UAC for my Pi3 because my Wi-Fi signal is bad at my bedroom.

Now the signal is amazing and I have no problem to connect to my 2.4GHz network, but the thing is that the adapter doesn’t found any 5GHz network (and I’ve tried with different configurations on my router, but nothing).

Anyone can help me?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Please describe what you tried.

Kernel Message Log
Kodi Log

  • Turning off the 2.4G network.
  • Changing the name of the 5G network.
  • Changing the band width (80MHz, 40MHz, 20MHz & Auto).
  • Changing the channel.

Would you please run grab-logs -A. The Kodi log is of no help in this case and the kernel log doesn’t give enough information.

grab-logs -A

I can see that it’s getting what seems to be the correct driver (8812au) and successfully connects to channel 6 (2437 MHz).

It might be worth installing CRDA at this point:

sudo apt-get update
sudo apt-get install crda

Then edit /etc/default/crda and set REGDOMAIN=ES. Save and reboot.

You need to be sure that 2.4 GHz and 5 GHz have different SSIDs. Then run

scan wifi

If that fails to see 5 GHz, try to connect through ethernet cable, reboot and repeat the wifi scan. You might also need to run enable wifi in this case.

This worked! Thank you very much dillthedog