Edimax Wifi Adapter Not Recognized

Hey Guys,

Totally new to the world of Pi and OSMC, but I’m trying to soak up as much as I can. Long story short, I purchased a Raspberry Pi 2 B and an Edimax EW-7611ULB WiFi/Bluetooth adapter to utilize Pi as a media server/DNS ad blocker. No matter what I do I cannot get OSMC to recognize the adapter. I did get it to work on Raspbian after many hours of painstaking fiddling but have been unable to recreate the success with OSMC. So far I’ve tried following the instructions on the Edimax website here (https://goo.gl/AgZPnD). I updated OSMC, downloaded the driver, and tried to compile it, but couldn’t find headers for the OSMC kernel. The wireless option does not display on the GUI setup or in connmanctl technologies. The device is listed under dmesg though. I’ve tried making sure it’s plugged in to a powered USB hub, increasing the max current to the USB ports, and unplugging the ethernet connection to give priority to wireless. Nothing will get wireless to show up as an option for me. Here’s a paste of some logs I thought might be relevant, and I’m more than happy to provide any others (http://paste.osmc.io/foyogajaka.md) Any help would be greatly appreciated!

Thanks,
Matt

sudo apt-get update
sudo apt-get install rbp2-headers-$(uname -r)
1 Like

Thank you! That successfully allowed me to install the kernel headers. I then hit another roadblock when I went to compile (it’s telling me there’s no build directory). I posted the logs here.

http://paste.osmc.io/uxusaxeyos.mel

Thanks again,
Matt

Well, it’s not lying since /lib/modules/4.9.29-13-osmc/build doesn’t exist on OSMC. Fortunately, I have a Pi1 running Raspbian and can see that /lib/modules/$(uname -r)/build is actually a link to /usr/src/linux-headers-$(uname -r).

Naming on OSMC is a little different, but you need to change the line:

KSRC := /lib/modules/$(KVER)/build

to

KSRC := /usr/src/rbp2-headers-$(KVER)

Plus read the README about concurrent mode.

PS I only got it to build so no guarantees about make install.