Emby for Kodi


#1

Anyone else having trouble upgrading Emby for Kodi on OSMC?
https://emby.media/community/index.php?/topic/21888-emby-for-kodi/page-18

Even if you try to manually update it, nothing happens.
It shows the new version, but won’t install it.

It works fine (auto updated) on windows PC with Kodi


#2

I’ve just updated Emby for Kodi on my Vero 4K units. No issues noted.
From Kodi addon-settings I’ve always specified for Notify but do not download automatically.
From the Addon menu the Emby addon was reported as available update. So I completed a manual update.
Update downloaded now at 4.0.0.1
The update was a little time consuming and require resetting the Kodi Database to reload the libraries. So I would recommend reading the wiki on the addon update.
Hope the update goes well for you as I’ve noticed a big performance jump in combination with the server update too.


#3

Thanks for the answer.

Yes, I know it’s a very big update/change, and I have to reset database afterwards.
I’ve done all that on Windows PC kodi, but tried with several Vero 2 and Vero 4K boxes now.
Can’t update a single one of them.

Weird.


#4

Hey there Smasher.

I just stumbled across your post. If you were on stable previously, make sure you update the dependencies. That’s probably where it’s getting stuck. Otherwise, provide a Kodi log on the Emby forums and I’ll have a look. You can find the dependencies here:

http://kodi.emby.media/Public%20testing/Dependencies/


#5

People’s Vero boxes are FINALLY starting to update to 4.0.1, don’t know why it took so long, and why I couldn’t force it to update on my own.
Especially when it worked perfectly on Windows Kodi.

But it should be working now… slowly :wink:

Thanks for the hard work with Emby addon :slight_smile: