Enable wifi to ethernet bridge mode


I am trying to bridge Wifi to ethernet
but got an error

How to disable hotspot mode?

any guide to bridge wifi to ethernet? did not find any in the forum

Thanks T

Hotspot mode (tethering) is disabled by default. If you mean a true bridge (ie WiFi and eth on the same subnet) I can’t recall anyone doing that. Otherwise use tethering but you need some extra steps - a static route in your main router and possibly some iptables stuff on the Pi.

What error?

stangewise no entry in kodi.log, do I need to enable debugging?

do you have an example of configuring bridge mode? do you use hostapd service for that?

Looks like having a permission issue?

script.module.osmcsetting.networking[networking_gui] : Enabling ethernet Hotspot 
2022-07-24 16:09:32.857 T:3914    DEBUG <general>: Enabling ethernet tethering
2022-07-24 16:09:32.858 T:3914    DEBUG <general>: 
2022-07-24 16:09:32.862 T:3914    DEBUG <general>: Error enabling Tethering net.connman.Error.PermissionDenied: Permission denied
2022-07-24 16:09:32.863 T:3914    DEBUG <general>: 

I think there’s some bugs in My OSMC networking which are being worked on. Try using connmanctl. Something like connmanctl tether ethernet or type connmanctl then help or technologies to see what’s going on…

ok thanks, will check