Enable wifi under GUI

Edimax EW-7811Un does not work too. Thank you.

Hi having issues with D-Link DWA-121 it the dongle has power but cant find my network works under old raspmc but not in OSMC finds my phone if i turn on hotspot any clues to why it cant find the wifi network when the older OS finds it ?

Is it possible to just switch wifi adapter if I buy new edimax.
Must I reinstall osmc or does It work just turn it of and plug in new wifi adapter.

Edimax EW-7811Un is working right?

Are you sure it’s not working ? According to this post that particular adaptor is actually working:

You don’t have a slightly different model by any chance ?

I think it’s working fine now. Just wondering because the status report is different between My OSMC and System > System Info. It shows Connected in OSMC but Disconnected in System Info and someone here told me OSMC is more reliable.
Thanks

After creating this topic, it looks like I have the same problem where my dongle is not supported in the RC (but it was supported in Alpha 4). My dongle is the Asus N-10 adapter and dmesg gives me this as the product/manufacturer details: Realtek 802.11n WLAN Adapter.

Someone had mentioned a problem here previously with that same dongle, but it was working just fine for me on Alpha 4. Now that I’ve upgraded to the RC it is no longer working.

Having same problem with EW 7722U, blue light doesn’t flash.

Everyone please see this thread [RC] - Added WIFI adapter support requests - Official topic - #5 by inspector

Just tried RC version, below Wifi dongle still not supported, looks like drive not added. Pls fix it. ASUS AC56

2.460832] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[ 2.561469] usb 1-1.2: New USB device found, idVendor=0b05, idProduct=17d2
[ 2.561503] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.561522] usb 1-1.2: Product: 802.11n NIC
[ 2.561538] usb 1-1.2: Manufacturer: Realtek
[ 2.561553] usb 1-1.2: SerialNumber: 123456

This worked perfect.
My only comment is, I had to search for this a long time. More common messages is all about building drivers, kernels etc. I am just a simple user, and don’t want to build my own kernels and drivers. Special if this is not nessesary. My search for setup the wifi and to find this, was over three hours. Is there a manual on how to do those simple things ? That would be very usefull. Also for other user who are / wish not to be an expert and have about my brain capacity :smile:

The message you are replying to was posted on the 5th of February, back when the OSMC networking wifi GUI had not even been written yet. There is no need to follow those steps on RC2 as there is a fully working GUI for configuring your wifi connection.

If for some reason you are having problems with the networking GUI we need to know this so it can be fixed.

I was having problems with the networking GUI, so i had to follow the aforementioned instructions. I’m running RC2 on a RPi 2 with an 8GB SD card coupled with an 8GB USB stick installed during initial OSMC boot up (so i’m assuming some of the OS was moved to the USB stick, though i don’t know for sure… just read somewhere that it’s faster than the SD card alone).

With that said, i definitely could not get the network going during initial boot up (no network detected and the option to “manually configure” was not responding). After initial boot up i tried to use the network gui and was able to see my network, but was unable to get to the point where i put in my network pass phrase (key). In either case (initial boot up and subsequent attempt to configure with the gui), i didn’t wait very long after making certain selections and have since seen OSMC take a very long time to respond to my key strokes. So, maybe if i tried the gui and just waited longer, it would have worked.

Also, i don’t know how to reply such that the post i’m replying to is replicated in the blue box… so this post is a reply to DBMandrakes request for feedback with issues regarding the networking GUI

Hello! My installation has been working bug-free for several weeks, but I noticed tonight that my remote wasn’t working, and couldn’t ssh into my RPi. I checked the router and found that it wasn’t even connected to the network, so I plugged it directly into the router and successfully enabled the wifi using connman… but when I restart, the wifi doesn’t reconnect. Obviously the hardware is working, but as of now I can only access the pi when it’s plugged directly into my router via Cat5. Any ideas?

Yes.

Connman will not auto connect wifi when Ethernet is still connected. So make sure you unplug Ethernet if you expect wifi to auto connect.

Thank you, I will try that as soon as I am able.

HI,

I am using the May 16 release candidate on a pi B.

I am using an edimax 7811un dongle.

In this release, as with the previous release, I could not connect to my wifi router using the gui network config tool.

The router at home is using wep/open and the password is a normal 5 ascii key.

For both releases, I have to connect the pi to a wired lan so I can ssh to it from another computer. Via this route, I can successfully configure the wifi using the connmanctl .

Is there a way to fix the gui tool? I want to give my pi as a gift to some relatives who are not as technically savvy. I was hoping there might be something I can do to the network gui tool to make the configuration easier?

Thanks

Please start a new thread with a log and let us know what is on the screen when you enter your password.

This is an interesting problem

S

To set up a static IP, from within the connmanctl prompt:

config wifi_c83a35ca4314_535454657374_managed_psk --ipv4 manual <ip address> <netmask> <gateway>

EDIT Also set up DNS servers

config wifi_c83a35ca4314_535454657374_managed_psk --nameservers 192.168.1.254

Ditto. I’m guessing its due to lack of a driver? I only get the [wired] section.

Hi,

I am using Machine model: Raspberry Pi 2 Model B Rev 1.1.

I am having issues connecting to the router using my wifi dongle. It was working flawlessly until I upgraded my ASUS TR-n18U router firmware last week. Since then my wireless dongle has not been connecting to my router.

As mentioned at the start of the thread. using connect wifi_somethingsomething_managed_psk, I get an error message “Connect command not found”

I ran the sudo apt-get update && sudo apt-get dist-upgrade to ensure that I am using the latest distribution.

When I run dmesg , it seems to recognize the dongle

[ 3.071646] usb 1-1.3: Product: 802.11n WLAN Adapter
[ 3.071657] usb 1-1.3: Manufacturer: Realtek
[ 3.071668] usb 1-1.3: SerialNumber: 00e04c000001
[ 3.123780] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode.

I can also see the below

[ 5.670120] USB_SPEED_HIGH
[ 5.670229] CHIP TYPE: RTL8188C_8192C
[ 5.670270] register rtw_netdev_ops to netdev_ops
[ 5.670722] Chip Version ID: VERSION_NORMAL_TSMC_CHIP_88C.
[ 5.670735] RF_Type is 3!!
[ 5.670991] EEPROM type is E-FUSE
[ 5.671000] ====> ReadAdapterInfo8192C
[ 5.671084] Boot from EFUSE, Autoload OK !
[ 5.743876] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

9.125732] ssid=ASUS, len=4
[ 9.125750] Set SSID under fw_state=0x00000008
[ 9.125770] [by_bssid:0][assoc_ssid:ASUS][to_roaming:0] new candidate: ASUS(a c:9e:17:e9:ff:6c, ch6) rssi:-45
[ 9.125783] rtw_select_and_join_from_scanned_queue: candidate: ASUS(ac:9e:17: e9:ff:6c, ch:6)
[ 9.125808] link to Broadcom AP
[ 9.125825] <=rtw_wx_set_essid, ret 0
[ 9.125978] Set BSSID under fw_state=0x00000088
[ 9.125995] start_join_set_ch_bw: ch=6, bwmode=0, ch_offset=0
[ 9.246318] link to Broadcom AP
[ 9.255113] OnAuthClient
[ 9.255145] network.SupportedRates[0]=82
[ 9.255157] network.SupportedRates[1]=84
[ 9.255170] network.SupportedRates[2]=8B
[ 9.255180] network.SupportedRates[3]=96
[ 9.255190] network.SupportedRates[4]=24
[ 9.255200] network.SupportedRates[5]=30
[ 9.255209] network.SupportedRates[6]=48
[ 9.255219] network.SupportedRates[7]=6C
[ 9.255229] network.SupportedRates[8]=0C
[ 9.255239] network.SupportedRates[9]=12
[ 9.255248] network.SupportedRates[10]=18
[ 9.255259] network.SupportedRates[11]=60
[ 9.255270] bssrate_len = 12
[ 9.259486] OnAssocRsp
[ 9.259519] report_join_res(9)
[ 9.259537] rtw_joinbss_update_network
[ 9.259552] +rtw_update_ht_cap()
[ 9.259575] rtw_joinbss_update_stainfo
[ 9.259658] HW_VAR_BASIC_RATE: BrateCfg(0x15d)
[ 9.259801] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 9.261854] WMM(0): 0, a42b
[ 9.261999] WMM(1): 0, a44f
[ 9.262128] WMM(2): 0, 5e4322
[ 9.262255] WMM(3): 0, 2f3222
[ 9.262264] HTOnAssocRsp
[ 9.267925] update raid entry, mask=0xfffff, arg=0xa0
[ 9.269294] rtl8192c_set_FwJoinBssReport_cmd mstatus(1)
[ 9.270064] SetFwRsvdPagePkt
[ 9.270111] Set RSVD page location to Fw.
[ 9.270967] OnAction_back
[ 9.271001] OnAction_back, action=0
[ 9.271016] issue_action_BA, category=3, action=1, status=0
[ 9.271077] Drop duplicate management frame with seq_num = 4053.
[ 9.271441] =>mlmeext_joinbss_event_callback
[ 9.274856] Drop duplicate management frame with seq_num = 4053.
[ 9.553527] rtw_aes_decrypt:rx bc/mc packets,but didn’t install group key!!! !!!
[ 9.595879] rtl8192c_dm_RF_Saving(): RF_Save
[ 9.860767] rtw_aes_decrypt:rx bc/mc packets,but didn’t install group key!!! !!!

Can anybody help ?

THanks in advance.

Arun