Enabling composite video output on RPi 2 within OSMC? - SOLVED

Hey guys,

I have my raspberry pi 2 plugged using a 4-pole composite cable. It works fine when i plug in HDMI, but I don’t get any signal through the composite a/v output. Any ideas?

I’m using this cable: http://www.modmypi.com/raspberry-pi/accessories/audio-cables/av-composite-cable-3.5mm-to-3-x-rca-3m and I have the red connector plugged as in the video input.

Thanks in advance.

David

It would make sense that when connected by HDMI, composite is disabled. I think it’s unlikely that the pi could push dual video over both outputs simultaneously.

Just to be clear, I only want it to output through analog, not both. Shouldn’t it be automatic?

Yes, make sure the HDMI is disconnected when you boot it.

I have tried that, but unfortunately there’s no signal.

Did you try yellow and black?

Yes I’ve tried pretty much every combination. Odd thing is that if I plug in the HDMI and switch to that input, the signal is working. Is there a way I can force it to output to analog instead of HDMI? I haven’t seen anything in the settings.

Unfortunately, I’m rather new to OSMC and the RPi in general. Any help is really appreciated.

I figured it out. I edited the config.txt file by adding:

hdmi_ignore_hotplug=1
sdtv_mode=0
and commented out hdmi_safe=1.

Seems to work, now I just need to see if I can do something about the background noise.

You should not have had hdmi_safe=1 in your config.txt in the first place.

It is not there by default in OSMC and it will (among other things) force HDMI output.