Enabling WOL on 4K

Hey guys,

So I SSH’d into my box now and did the customary poking around and much to my delight I saw that the ethernet chip did support WOL.

ethtool eth0
Settings for eth0:
Supported ports: [ TP AUI BNC MII FIBRE ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
Transceiver: external
Auto-negotiation: on
Supports Wake-on: ug
Wake-on: d
Current message level: 0x0000003f (63)
drv probe link timer ifdown ifup
Link detected: yes

However setting it proves not to be so good.

ethtool -s eth0 wol g
Cannot set new wake-on-lan settings: Operation not supported
not setting wol

Can someone enlighten me as to why this would be so. Far as I knew there were no physical connections needed for WOL it is just something that is built into the interface. So why can it not be changed? Is this some sort of exotic ethernet device that pehaps needs a driver rewrite?


A post was merged into an existing topic: Enabling WOL on 4K