Enter key no longer works from guide

Since the last update, pressing Enter (on a keyboard) from the TV or radio programme guide no longer brings up programme information. To watch or record I now have to go via the context menu.

Is this design or accident?

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

I have an RPi2 with USB TV tuner, WiFi dongle and BT dongle, connected to a Panasonic TV. I control it from a BT qwerty keyboard. Before last week, if browsing the TV guide, I would hit Enter and a window would pop up with the programme description and options to switch/set timer. Now, I don’t get a window popping up, although I do get the swishing noise indicating that osmc has registered the key-press.

Log is at paste.osmc.io/oxesadiziq

This morning, I tried the TV’s CEC remote and pressing OK has the same effect - no pop-up window, just a swishing noise.
Then I switched to Confluence and the Enter key worked as expected.
I don’t seem to have any relevant keyboard customisations, just this in keymaps/gen.xml:

<keymap><fullscreenvideo><keyboard><key id="61626">fastforward</key><key id="61627">rewind</key></keyboard></fullscreenvideo></keymap>

Thanks for your help.

From the log:

12:04:27 58.277988 T:1958249008 DEBUG: OnKey: return (0xf00d) pressed, action is Select
12:04:27 58.278221 T:1958249008 DEBUG: ------ Window Init (DialogPVRInfo.xml) ------
12:04:27 58.278313 T:1958249008 INFO: Loading skin file: DialogPVRInfo.xml, load type: LOAD_EVERY_TIME
12:04:27 58.289677 T:1958249008 ERROR: unable to load:/usr/share/kodi/addons/skin.osmc/16x9/DialogPVRInfo.xml, Line 0
Failed to open file

DialogPVRInfo.xml is missing from the directory. What next?

Does it work if you select a different Skin ?

Quote: [quote=“grahamh, post:3, topic:13691”]
Then I switched to Confluence and the Enter key worked as expected.

Looks like that function is not currently supported in the OSMC skin then.

Well it was OK a month ago, and this (I’ve just discovered) fixes it:

osmc@osmc:/usr/share/kodi/addons/skin.osmc/16x9$ ln -s DialogPVRGuideInfo.xml DialogPVRInfo.xml

so it looks like a someone typed a filename wrong, somewhere.

I should reword my comment to be more clear - not currently supported in the OSMC skin in Jarvis.

There are changes in Jarvis that require skins to be updated - I’m not sure that this has been done in the OSMC skin yet hence the suggestion to try a different skin to see if it is skin related.

(I don’t use / have access to a PVR setup so I can’t test it myself)

I see. Well, for some reason DialogPVRGuideInfo.xml is now called DialogPVRInfo.xml. There is a file of this name in Confluence, but not in the OSMC skin. Should I raise a bug, or will it be picked up from here?

I searched in vain on the kodi site for advice for skin developers on moving from Isengard to Jarvis. If there is such a thing, I could go on a bug hunt if that would help. Edit: found it on the kodi forum - a bit daunting, the number of changes!