EPG data lost

Hello,

after one or two weeks where in worked fine, now my PVR has got a completely empty program guide. The structure still is visible, but no entries at all. The same at the “channels” menu.

At tvheadend, I can see all program data.

Strage:
After reboot, for 1-2 minutes I can see program data at “channels”, but they will disappear. The same happens when I manually update EPG data for a certain channel: They will populate program guide, but disappear within a short period.

Let me know if you need logs or more info.

Greetings,
Wolf

Does really nobody have an idea how to track down this issue? - It’s so essential to TV…

Cheers,
Wolf

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Ah, thank you, I should have known that on my own.

Now: Did 2 reboots, PVS started, EPG info was aquired, but lost within less than a minute. Aquired them again for 2 channels manually - these were then visible in EPG guide (that particular channel only) and again vanished within one minute.

Logs are here:
https://paste.osmc.tv/idegubihay

Cheers,
Wolf

Hi,

Does issue occur with a different skin. e.g. Estuary?

Thanks Tom.

Yes, I tried 3 different ones.

Can I reinstall TV services without loosing my settings?

Hi,

P try disabling TVHeadend HTSP. Then go to settings Live TV, general and clear data; do the same under the guide menu. Then re-enable TVHeadend HTSP

Thanks Tom.

Thank you. So I did:

  • deactivate TVheadend client HTSP in settings > user addons > PVR clients
  • went to settings > PVR and TV > general; deleted data
  • went to settings > PVR and TV > EPG; deleted data
  • activate TVheadend client HTSP in settings > user addons > PVR clients

Hope these are the steps you described.

In fact, program guide will populate again - partially - with a number of entries. But again, they disappear in half a minute or so.

Sorry. What else should I do?

Hi,

Others may have more ideas, but All I can suggest is a fresh install on a new sd card and restore your settings from a backup.

Thanks Tom.

Thank you very much.
I tried a reinstall, but failed with the widely mentioned RPI4/HDMI-problems. So I’ll wait till these are resolved. (No idea how I circumvented these at my first install)