EPG Grabber module tab in tvheadend not showing


I have had Vero 4K+ for a while, and just recently I tried to configure tvheadend 4.2.8 on it. As the add-on seems to work fine, I cannot get the “EPG Grabber Modules” tab to show. I’ve read many posts regarding the issue, and found that “Persistent user interface level” in General->Base should be checked, as well the “User interface level” should be Expert mode.

Right after checking the box next to the “Persistent user interface level” and saving the change, all configuration tabs disappeared from the menu. Only “Electronic Program Guide”, “Digital Video Recordrer”, “About” are visible. I no longer see “Configuration” tab, Login link, storage space. I cleared cache in the browser, tried different computer. No changes.

Why did this happen? Is there a way to restore all tabs again?

I have tried tvheadend 4.2.8 on a different platform LibreELEC on RaspPi3b+ (hope I can say this here), and all tabs, including “EPG Grabber modules”, are visible, no issues at all.

Looks like you managed to remove the admin right of the used tvheadend user. First, a question:

Where did you get this thveadend version from?

Two ways to solve this

  1. remove folder /home/osmc/.hts and restart the system. This will restart tvheadend from scratch and you have to configure all, again.
  2. The config file(s) of the used thveadend user you find at /home/osmc/.hts/tvheadend/accesscontrol. With an appopriate editor change the “admin” item to true and restart the system.

I managed to get all tabs, including the “EPG Graber Modules”, available by deleting folder /home/osmc/.hts, uninstalling Tvheadend in OSMC App Store, rebooting the system, and then reinstalling the Tvheadend from the OSMC App Store again.

Originally, I installed Tvheadend via cli: sudo apt-get install armv7-tvheadend-app-osmc, which seems to be the same file downloaded from the app store.