EPG help. Enable the grabber and get the xml from the url into tvh server on osmc?

i’ve been everywhere and i collected many bits of incomplete (and I’m more confused now) data and code (because they all do it differently). i need some pointing the true right, osmc, direction re: getting the epg up and running in TVH server.

i simply need to add the right few lines in the right few places, just cant get my head around it, yet…

One. i need to enable/config web grab (and give it the url of my xml file)…? big question.

Two. thus i should be able to select it in this area as an internal grabber (see above pic), right?

Three, lastly, script the cron tab to run/read/save the xml to a file (sockit?)
(btw this cron tab script (Three) can be edited right into the box in above pic? after 4 * /12 * * * *…right?)

Hi

This should be the same for TVHeadend as on any other system.

I’m not that familiar with webEPG since Radio Times started to charge for it, but have you seen: EPG Grabber - Tvheadend 4.0

Sam

update: installed xmltv-util and then tried and failed to manually download epg data from url :(.
theory is: once there is epg data for tvh to read, tvh will respond accordingly.

using the putty connection

sudo apt-get install xmltv-util

(appears successfully installed) rebooted. but nothing changed in TVH Server. No Grabber.
changed a Users setting in TVH. Use interface level Basic to Expert. Saved

then this…trying download my epg url…for one time epg data grab (manual)

(…while logged into directory) osmc@vero:~/.xmltv$

wget http://iptvepgprovider.com/000b-xxxx.xml.gz

–2020-03-13 11:28:04-- … connected.
HTTP request sent, awaiting response… 404 Not Found
2020-03-13 11:28:05 ERROR 404: Not Found.

ok gtg have lunch

This means that the XML file isn’t available at the URL provided.
Maybe you have to be logged in to get it.

1 Like

i ran the wget again and it worked, lunch (and Sam too) helped.

osmc@vero:~$ cd .xmltv
osmc@vero:~/.xmltv$ ls -al
total 1276
drwxrwxrwx 2 osmc video 4096 Mar 13 16:30 .
drwxr-xr-x 9 osmc osmc 4096 Mar 12 07:30 …
-rw-r–r-- 1 osmc osmc 1297386 Mar 13 16:30 10000-xxxxxv.xml.gz

thats my url .xml file in the .xmltv folder :slight_smile:

scanned the vero log didn’t notice any changes with tvh.

looks like the issue is getting tvh to recognize my xml, continuing my search for the know

good news

Check Configuration -> General -> Base -> View level. Change that to expert and save.

up pops the epg grabber modules tab. and again nothing there, well, there’s all the various regional OTA grabbers (, nothing that can be identified as a module that holds my prepared url epg

will keep looking for more know

still on Grabber Tab, looking at ;

XMLTV, External Grabber which has a path… /home/osmc/.hts/tvheadend/epggrab/xmltv.sock

guess, this is the part where i move my downloaded epg into the sock

I’m trying to run this line and receiving error ‘socat command not found’

osmc@vero:~$ #!/bin/bash
osmc@vero:~$ sudo cat .xmltv/10002-vXXXXv.xml.gz | sudo socat - UNIX-CONNECT:/home/osmc/.hts/tvheadend/epggrab/xmltv.sock
sudo: socat: command not found

any help would be appreciated, thanks

got my own answer

$ sudo apt-get update && sudo apt-get install socat

The following NEW packages will be installed:
socat
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 329 kB of archives.
After this operation, 821 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian stretch/main armhf socat armhf 1.7.3.1-2+deb9 u1 [329 kB]
Fetched 329 kB in 0s (369 kB/s)
Selecting previously unselected package socat.
(Reading database … 36661 files and directories currently installed.)
Preparing to unpack …/socat_1.7.3.1-2+deb9u1_armhf.deb …
Unpacking socat (1.7.3.1-2+deb9u1) …
Setting up socat (1.7.3.1-2+deb9u1) …

Socat is installed. my,

#!/bin/bash
sudo cat .xmltv/10002-vXXXXv.xml.gz | sudo socat - UNIX CONNECT:.hts/tvheadend/epggrab/xmltv.sock

produces an

2020/03/16 10:27:10 socat[21925] E connect(5, AF=1 “.hts/tvheadend/epggrab/xmltv.sock”, 35): No such file or directory

so, im looking to create ‘xmltv.sock’ …?

had a good look around…chmod? wget? anybody help? thanks

lunch always helps (hopefully the restaurant is open:)

finally figured nout how enable the grabber…

In tvheadend. Configuration, Channel/EPG, Internal grabber, module. Doubleclick box and select your grabber.

running the sock script…

osmc@vero:~$ #!/bin/bash
osmc@vero:~$ sudo cat .xmltv/10002-vXXXiv.xml.gz | sudo socat - UNIX CONNECT: .hts/tvheadend/epggrab/xmltv.sock
2020/03/16 17:42:58 socat[24909] E exactly 2 addresses required (there are 4);
use option “-h” for help

doing that now

osmc@vero:~$ sudo cat .xmltv/10002-vXXXiv.xml.gz | sudo socat - UNIX CONNECT: .hts/tvheadend/epggrab/xmltv.sock

I don’t know why you’re doing what you’re doing but the syntax seems to be wrong:
It should be UNIX-CONNECT: with a hyphen.
There should be no space after UNIX-CONNECT:

Other points:
I have no idea whether you should be sending a gzipped file to the socket. Perhaps it should be uncompressed first.
I also doubt that you’ll need sudo to cat the file. Are you also sure you need sudo for the socat command?