Equivalent of HDMI_FORCE_EDID_AUDIO on the RPi?

What is the best way to spoof the Vero4K into allowing it to pass audio formats that my system reports as not support? On the RPi I used to set HDMI_FORCE_EDID_AUDIO in config.txt, though obviously not available on the Vero.

I have an old AVR with no HDMI and an SPDIF de-embedder box to drive it with AC3 and DTS, though my projector is obviously advertising zero audio capabilities in EDID.

I’m sort of getting audio at the moment, but I think just the front left and right out of the 5.1 stream.

You should be able to set the formats you want via Kodi and we will override any EDID information.

If the EDID reports itself as a DVI device it’s a bit different, but we can help resolve that for you. I remember we had to make the same provision for a Vero 2 customer who was using a defective HDMI cable that was buried in the wall.

Can you post some logs so I can see how the kernel is treating your device?


Have reset the audio de-embedder this morning, and I think I’m getting 5.1 this time. Log as requested.


As a by-the-by cat /sys/class/amhdmitx/amhdmitx0/aud_cap doesn’t list anything as available.


That shouldn’t matter.

I’ve had a quick look and it looks like your projector is advertising itself as an HDMI sink, so Vero 4K will send sound.

If you take a screenshot of your audio settings and post here, I’m sure we can advise.