Error 8216 when trying to use SMB

I finally had time to install my new Vero 4K+ bought several months ago.
As with the older one, it is setup as a client and a Synology NAS is the server.

Following the same steps that I used with the older one, I setup SMB as the protocol (still having problems with NFS), but SMB has been working quite well with the older 4K+ to play videos.

The problem is that I am getting an “Unknown Error 8216” when trying to add files to it.

Steps I am taking:

  1. Setup the new 4K+, connected via cable to my home network switch.
  2. 4K+ sees the network and acknowledges it’s connected to the Internet in the system information section.

Option 1:
3) Go to System and open File Manager
4) Go to “Add Source”
5) Kodi opens a pop-up “Add File Source” window and I click “Browse”.
6) Select "Windows Network (SMB) option
7) System pops-up the “Unknown Error 8216” message

Option 2:
3) Go to System, Media and “Add Video Source”
4) Follow the same steps outlines above
5) Get same error

Option 3:
3) Go to System, Media and “Add Video Source”
4) Follow steps 4 and 5 in Option 1
5) Instead of selecting the “SMB”, select “Add Network Location”
6) add server IP address, shared folder path, username and password, using SMB as the protocol selection
7) Kodi now gives an “Unauthorized Operation” error message. I wonder if it can be related to the error that pops-up with the steps in options 1 and 2.

I am following the same steps used with the older one, which worked fine and is still working fine.

I checked the Kodi version and both say “Build OSMC Running Kodi 18.9, Compiled 2020-11-27”

Any detail I am missing? No changes in the Synology configuration and the older 4K+ is working fine.

Thanks much!

I think I read something about this error. It was related to SMBv1 browse capacity (or the lack of if you’re above v1). A simple check would be to add a new SMB source directly with the IP (no path defined, just the IP) and of course the correct credentials. After you should be able to navigate in the folders available

Having the NAS only authorizing SMBv2/V3 may also avoid such as nothing will be shown on the network without SMBv1 enabled (disabled for security reason).

Hello Shamael.
Thanks! I followed the instructions on this post:,-media-server,-windows-share-or-other-device/

Using the following string: smb://user:password@SERVER/sharename/folder

For movies:
For TV Shows:
smb://OSMC:password@ Shows


  1. is my NAS’ IP address
  2. I use the actual password when inputting the string. Did not post it for security reasons.

However, I get an error message saying that the access is not authorized. I used it with the other 4K+ without issues. Not sure why it’s not working now, since the other is still working fine.

I also tried setting only the NAS’ IP without a defined folder path, but it also did not work.

Probably missing some detail…

The Synology NAS software (DSM) offers the option to set the minimum SMB protocol as “SMB2” or “SMB2 and Large MTU”. It’s currently set as SMB1 and was not necessary to change for the other 4K+ (running the same software version as this one).

However, I can try changing it to one of those two. Which is better?


Set the SMB2 version on the NAS, The highest the best but all clients need to be able to use SMBv3 if this is the minimum selected. Test with SMBv2 and make it work first.

-On the NAS the user OSMC is defined and authorized? Any logs visible showing the connection attempt?
-What’s the Vero maximum SMB Level (shown in your link, last screenshot)?


Yes. The user OSMC is authorized in the NAS and the older 4K+ has been accessing the folder without any issues.

Mine is showing as SMBv3 as maximum and “none” as minimum.