Error after updated to Jan 2023 update

Updated to latest OSMC Jan 2023 update. When the Vero4K+ restarted. The following message appeared. I turned off the system, pulled out the SD card just to verify that wasn’t the issue. The error remains.

I cannot SSH into the Vero4K+ right now. I am thinking I need to get out a USB stick and do a clean reset. Any other ideas.

Connect a USB Keyboard and check what causes the dependency. How to create the mount for the SD Card and what do you store on the SD Card?

Thanks. I hooked up the keyboard. I could type in commands and see dmesg and journalctl. I tried to grab-logs but it fails on line 1031.

Do you have a USB drive attached?


Let’s start with the fstab
paste-log /etc/fstab

I am thinking the SD card is starting to wear out after 5+ years of use. There wasn’t any SD cards or USB drives attached and the system still hung at the same point.

I was able to nano into /etc/fstab and comment out the UUID line for the SD card and the system rebooted back to KODI.

I now have two folder under samba for the Vero4K+.

The sd folder is where the uploadlog.txt is when I tried grab-logs previously. The reinstalled SD card is also mounted with the same GUID number.

There is only a sd folder under the /mnt folder.

Thank you for your help. Is there a way to remove the sd folder and rename the GUID’d folder back to sd

I am confused. After the successful reboot, I decided to uncomment out the line in fstab about the GUID. The system rebooted just fine and everything is back to normal. I don’t know why this occurred. I was able to grab the logs it created when it was down though.

Everything is back as it should.

Share your fstab entry, you should not mount external cards with options that would stop a successful boot

1 Like

This FSTAB entry has been there for years with no issues. I don’t know why upgrading to the latest version of OSMC caused the boot to hang at this point.

 UUID="9d25e14e-f813-4399-a2fa-df7ae978a092" /mnt/sd ext2 defaults 0 0

I think I was trying to get a better name (or to show up as a networked folder) on my WIndows machine and that is why I did this. If there is a better method I am more than happy to learn and adjust.


  1. OSMC does automount and autoshare of storage devices based on their label. So as long as you give your SD Card a good label it will show up nicely without the need for fstab entry.

  2. If you still want to use an fstab entry suggest to use nofail option to avoid that the boot process stops in case SD Card can not be mounted on boot

Ok. Great. Is there a way in OSMC to give it a name? I am pretty sure I formatted the SD card as EXT4 which means I can’t read it on my Win10 machine.

Use the command e2label

Thank you for the command. After a restart, I saw it listed as a network folder. I wasn’t sure where the new mount point was, so I found the command lsblk to show the current mount point under /media

I appreciate all the help… once again.