Error creating demuxer on official addon

Trying to watch the Nederland NPO 1 live stream. Getting error, in the log it says “error creating demuxer”.
I’m in NL, so I am allowed to see it.

What add-on are you attempting to use?

Did you seek support from the add-on developer?

Where are your debug enabled logs?

1 Like

Thank you for your reply.
The add-on is: Add-on:Nederland 24 - Official Kodi Wiki
I wanted to watch the Olympics, which are geo locked. As said, I’m in NL, so that shouldn’t be the issue. I remember from another add-on that didn’t work about a year ago, it was due to DRM protected streams. At that time, it was being worked on.
Is that the issue?

Happy to post a debug log later on if required.

We cannot help you with any of this. You should be addressing the issue with the addon developer if you think there is a problem. This is not an OSMC issue. Good luck.

Sorry as I said, I am in The Netherlands right now, so I am allowed to watch this stream. E.g. it works fine from my laptop.

I remember from last year that such streams are not supported in the current Kodi / OSMC version at all. At that time it was said to be fixed soon.

I’m not doing anything illegal here…

@ActionA this was the topic I’m talking about: Netflix or Amazon with Vero4K - #5 by Smurphy

Is that related?

Not likely.

Nobody said you were. What was said is that it’s an add-on issue and you should contact the developer for help. If the problem is DRM related then it may have to wait for Kodi 18 for a fix, but again that’s a question for the add-on developer.

It may be related to some of the uname changes that were made as part of the Netflix and Amazon enablement patches.

If that’s the case, it should start working for you in the next update

Otherwise, we will indeed need some debug logs for us to be able to proceed further



Thanks Sam.
I’ve given up, not worth the hassle, we’ll watch on the laptop.

Unfortunately OSMC/KODI is not a full replacement for what you can do on a laptop in terms of streaming. I’ve been struggling for hours as well to connect to an OpenVPN, which is a breeze on a laptop.

OpenVPN is very simple after the December update. Prior to that, it was more tricky.

Download the Brian Hornsby VPN add-on, and that’s it. If you encounter any problems, please start a forum post and let us know what’s not working so we can help.

The next update should also allow you to use the Nederland add-on as well, assuming that the problem was related to how Vero 4K reports its machine architecture.

You haven’t provided a debug log however, so this is a complete stab in the dark. If you do so, I am confident we can get this to work for you very promptly.

Please help us help you.


Okay Sam, will give it another try, and upload debug logs if it still doesn’t work. Thank you for your kind reply :slight_smile:

You’re welcome. Let’s get this sorted :slight_smile: