"Error Enabling Hotspot" after October update

Tethering was fine before the update. I’ve had a look around here and tried ‘connmanctl tether wifi on’ manually but got Permission Denied.

Thanks in advance

RPi3B with USB wireless eSynic keyboard/mouse and external hard drive

The logs are after reboot then immediate attempt to enable tethering :-

2019-11-06 15:33:50.115 T:1377039072 DEBUG: Enabling wifi Hotspot
2019-11-06 15:33:50.115 T:1377039072 DEBUG: Hotspot ssid = osmc_wifi
2019-11-06 15:33:50.125 T:1377039072 DEBUG: Enabling wifi tethering
2019-11-06 15:33:50.128 T:1377039072 DEBUG: Error enabling Tethering net.connman.Error.PermissionDenied: Permission denied

http://paste.osmc.tv/igaromowor/

Unfortunately the WiFi driver for the internal BCM WLAN on Raspberry Pi does not support nl80211 based tethering on 4.19.

Thanks for the prompt reply. I’ll revert to the older version. Is this the end for tethering in the future?

Possibly something to add to the Miscellaneous notes on the October update blog post?

ps.

Did you ever finish at Kings?

You’ll probably get away with staying on 4.14 for another year.

Not sure when support will come back, but it will come back.

I finished over 4 years ago.

Time flies. I joined 8/1/15 and it’s been 4 and a half years since my last post i.e. problem that couldn’t be solved by searching here. I’ll speak to you again in a few more years. All the best.

1 Like

Is there a quick way to revert the kernel to 4.14 or do I need to reinstall an earlier OSMC version and then turn off updates?

See After october update HIFIberry Digi doesn't function

Thanks! Tethering works again.

I use OSMC on RPi3 to power a media center in my minivan. Kids get the screen in back and the adult in the passenger seat can control everything from a phone without needing to see the screen. It’s brilliant.

While that did work, I was thrown off by the install appearing to fail. I’m going to include the below to help anyone else trying to do this.


Verify current kernel:

osmc@osmc:~$ uname -a
Linux osmc 4.19.55-6-osmc #1 SMP PREEMPT Sun Nov 3 22:15:28 UTC 2019 armv7l GNU/Linux

Reinstall appears to fail:

osmc@osmc:~$ sudo apt-get install --reinstall rbp2-image-4.14.78-4-osmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reinstallation of rbp2-image-4.14.78-4-osmc is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I can see the kernel in apt:

osmc@osmc:~$ apt-cache search rbp2-image
rbp2-image-4.19.55-3-osmc - Linux kernel binary image for version 4.19.55-3-osmc
rbp2-image-4.19.55-4-osmc - Linux kernel binary image for version 4.19.55-4-osmc
rbp2-image-4.19.55-5-osmc - Linux kernel binary image for version 4.19.55-5-osmc
rbp2-image-4.19.55-6-osmc - Linux kernel binary image for version 4.19.55-6-osmc
rbp2-image-4.14.78-4-osmc - Linux kernel binary image for version 4.14.78-4-osmc

And it looks like the 4.14 kernel is still installed:

osmc@osmc:/boot$ ls -la /boot | grep 4.14
-rwxr-xr-x  1 root root 2063640 Dec 12  2018 System.map-4.14.78-4-osmc
-rwxr-xr-x  1 root root  138397 Dec 12  2018 config-4.14.78-4-osmc
drwxr-xr-x  3 root root    2560 Mar 27  2019 dtb-4.14.78-4-osmc
-rwxr-xr-x  1 root root 8341128 Dec 12  2018 vmlinuz-4.14.78-4-osmc

So, I guess I don’t need to reinstall the old kernel at all, it’s still installed. Running dpkg-reconfigure was able to swap over to the older kernel.

osmc@osmc:/boot$ sudo dpkg-reconfigure rbp2-image-4.14.78-4-osmc
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.14.78-4-osmc /boot/vmlinuz-4.14.78-4-osmc
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal-osmc 4.14.78-4-osmc /boot/vmlinuz-4.14.78-4-osmc
run-parts: executing /etc/kernel/postinst.d/inform-updater 4.14.78-4-osmc /boot/vmlinuz-4.14.78-4-osmc
run-parts: executing /etc/kernel/postinst.d/process-vmlinuz-rbp 4.14.78-4-osmc /boot/vmlinuz-4.14.78-4-osmc

Verify current kernel:

osmc@osmc:/boot$ sudo reboot
# .....
osmc@osmc:~$ uname -a
Linux osmc 4.14.78-4-osmc #1 SMP PREEMPT Wed Dec 12 17:58:11 UTC 2018 armv7l GNU/Linux
1 Like

It seems that @sam_nazarko has pulled rbp2-image-4.14.78-4-osmc Perhaps he should consider returning it for the time being.