Error in osmc installer

Hi,
as my osmc installation did not boot any more (raspbian on an other SD card worked without any problem), I tried installing osmc on a “fresh” SD card. The setup program endet on 2 different Windows 10 computers with the error message
An error occured extracting the archive. Please consult the logfile.
This occured with version 2020.06-1 as well as with 2020.03-1.
If there really exists a logfile for finding the reason of the error, I’d look there, but there is no indication, where to find it…
What could I do for making an installation?
Is it possible to repair the bootsector?
Could it work to renew only a specific file for the boot proceedure?

The log file is under your user directory.

Thank you Sam.
However, I didn’t find it im my user directory, but in the Windows administrator’s user directory… and it showed a lot of entries.
The only thing I did was renaming the lof file and starting the osmc installer … and now, the installation run successfully. :astonished:
… I do not need to understand this and hope, osmc will no work as I was used during the last years

Here is what I know about this error message. If there are any osmc files already present in the relevant users directory (Windows 10 here), especially the .gz or .img files, possibly left over from a previous OSMC install or install failure, then OSMC will fail and it will issue this error message. In my case, the log file didn’t enlighten me about the problem. The last line in the log file was this

Sat 21. Nov 13:07:25 2020 Extracting C:/Users/myusername/OSMC_TGT_rbp2_20201019.img.gz

Another symptom of the problem before the error message even occurs is that the OSMC download progress bar never shows any progress.

Bottomline: Make sure the are no osmc img or gz files in the relevant user directory when you start the installer program.

1 Like

This shouldn’t be the case.

If you post full logs, I should be able to look in to this.

From what you’ve said, it just sounds like a permissions problem in your Downloads directory.
If download files are already present, the OSMC installer will prompt as to whether you’d like to re-download them.

Thank you Sam. I just deleted all the existing OSMC files in my user directory (including the log file), reran the installer and it worked fine the second time around.

Sam…I recovered the log file…in case you want to look … but as I am a new user…the forum won’t let me paste the whole log …I can only paste 5 lines…so here are the last 5 lines…

Sat 21. Nov 13:07:18 2020 Device selected: 2 F:\ 30528MB
Sat 21. Nov 13:07:24 2020 EULA has been accepted
Sat 21. Nov 13:07:24 2020 Downloading http://ftp.acc.umu.se/mirror/osmc.tv/osmc/download/installers/diskimages/OSMC_TGT_rbp2_20201019.img.gz
Sat 21. Nov 13:07:25 2020 Download successful
Sat 21. Nov 13:07:25 2020 Extracting C:/Users/Ginger/OSMC_TGT_rbp2_20201019.img.gz

Here is the whole log on pastebin

Unfortunately the link does not load.

Can you upload it to https://paste.osmc.tv?

Thanks

Sam

Here you go

https://paste.osmc.tv/loyamugoze.pas

Thanks. Are you sure that OSMC_TGT_rbp2_20201019.img.gz was already present on the system? This does not seem to be the case with your logs

Sam