Error installing update


I’m running OSMC on a RPi 3. Tonight when I tried to watch some recorded TV, I had this message on the interface: “Error installing update. Please report this on the OSMC forum.” Thus my post.

The interface was unresponsive when I encountered this message; i.e., I couldn’t move the cursor with my remote connected to my Flirc dongle. I had to unplug the USB power cable and plug it back in to reboot. On reboot, OSMC complained that it couldn’t start my PVR (because my backend was sleeping), so I ran AWOL to wake the backend and rebooted again. I was back up and running.

When I checked for an update, MyOSMC found none. I’m currently running OSMC March 2018 2018.03-2. Is that the most recent version? Something tells me I should be running an April release.

My update settings are as follows:

When updating, Download and display icon
Icon Position Horizontal (% of screen) 4
Icon Position Vertical (% of screen) 95

My Pi runs 24X7. What I’d like to happen is for any update to OSMC to be downloaded and installed unless I’m actually watching something. I can’t figure out what settings are correct, and I’ve never had an update installed without some kind of error, usually resolved by rebooting and then scanning for updates and installing.

I’m sure I’ve got something wrong, but tonight was the first time I encountered a problem where I was specifically advised to report it in the forums. So I did.

Thanks for any help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

It looks like I’m running the current release, so the update did install. I could not generate logs when I experienced the problem. I had to power-off and restart the Pi, at which point I assume the logging process starts over. That’s why I didn’t include logs. Maybe I’m wrong about that.

Next time we get close to the end of the month, maybe a day before a new release comes out, I’ll turn logging on and maybe pick up the problem I’m having. My experience is that logging consumes a lot of resources, and I don’t like to turn it on unless necessary. As I said, I’ve never had a new release install smoothly, but they always eventually install, so I’ve moved on.

I’ll submit logs if I can catch an update failure next time. For now, things appear to be “working”.

grablogs -a will provide a history of all updates and would still be useful even now. While things seem to be working at this point, it’s quite possible that you are not completely updated if you have received such error notifications.

grab-logs -a output here:

Thanks for any help.

From past similar posts, it seems that this error message can occur if there is a network issue while OSMC is checking for updates. The log of actual updates shows no recent errors.

Thanks for the response. My internet service was down for over two hours in the morning on 30 March. Perhaps that’s when it was checking?

Is it “normal” for the Pi to “hang” when there is an error in the update process? This has happened multiple times, and the only “fix” is to unplug the USB power port and plug it back in.

Thanks again for your help.

The message is something that has been reported before by other users, though I’ve not experienced it myself – yet – so I can’t say whether it’s normal for OSMC to “hang”.

You haven’t said what a hang entails. Are we talking about the Kodi interface becoming unresponsive or is it no longer possible to SSH to the Pi?

Ah, good point. I didn’t try to SSH into the Pi. I only observed that the interface became unresponsive. I’ll pay closer attention if this happens again.

I guess if I can SSH into the Pi, I can issue a shutdown -r command to reboot without having to unplug and plug in the USB power plug.

Thank you.

Better to try

sudo systemctl restart mediacenter

before going for the reboot.