Error installing update


Early today I updated OSMC on my pi3 with no problems, but as I was having issues with video playback stuttering, I checked for updates to make sure OSMC was up to date. A download bar appears in the top right as always, but when it’s done it prompts me with “Error installing”

I was not sure which logs were relevant, so here are they all:
If anyone could shed light over why the install fails and why I experience stutter, I would be overly happy.

I have a Logitech K400r connected to the Pi and a WD Elements HDD using a WD PiDrive cable, which is where the file is playing from.



I can’t see any issues with the update, you could check via the command line:


sudo apt-get update
sudo apt-get dist-upgrade

Advise if errors are reported.

It looks like your pi3 is under underclocked which would explain the stutters. If you’ve enabled the overclock settings in my osmc disable them and reboot (they were setup for older Pi models), if not remove these entries from the pi config (config.txt):


Thanks Tom.

Thanks for your reply Tom

I do get an error when running the command, but it isn’t related to OSMC, but another service I have installed. Could this still trigger the “Error installing” pop-up? If so, I’ll try to remove the program causing the error.

In regards to the buffering, I tried to delete the mentioned lines from the config. It seems I have an even more severe issue now, when I try to play high quality 1080p movies, they are just black. I can see the timeline moving along, but no sound is audible and no video is displaying. If I try to play a lower quality 480p file, the audio is coming through, but the video is still black. If you need updated logs, they are here:

I appreciate your help


Not sure whats going on here but it doesn’t look healthy, you could try removing the noob generated entries in pi config and just leave these:


Thanks Tom.

Thanks Tom

After a couple restarts, it was playing again, but with stutters. I will try to remove the generated entries.

The pi is not what I thought it was, it is a model B+ from 2015. Could this be why? It simply isn’t powerfull enough to flawlessly play big 1080p files?

Appreciate it


Could you please provide mediainfo for the videos you’ve been trying to play.

Thanks Tom.

i too am getting error installing osmc update errors; manually from cli:
sudo apt-get update
Get:1 stretch/updates InRelease [94.3 kB]
Ign:2 Index of /debian stretch InRelease
Get:3 Index of /debian stretch-updates InRelease [91.0 kB]
Hit:5 Index of /debian stretch Release
Hit:4 Index of /osmc/osmc/apt stretch InRelease
Get:6 stretch/updates/main armhf Packages [346 kB]
Get:7 stretch/updates/main Translation-en [169 kB]
Fetched 700 kB in 5s (139 kB/s)
Reading package lists… Error!
E: Problem parsing dependency 20
E: Error occurred while processing aa3d (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_stretch_main_binary-armhf_Packages
E: The package lists or status file could not be parsed or opened.

Probably a failing SD card, but without logs it’s just guessing. Also: Cant login via SSH and alternate segfaults/sad face [SOLVED] - #5 by hal8000