Error installing: vero2-device-osmc

Hi all!

Having just received my Vero2 I tried to install TVHeadend Server via My OSMC/App Store. I then get an error message “Error installing: vero2-device-osmc”.
There is also an error message when running a manual update via My OSMC/Updates which reads “OSMC Update error, Error installing vero2-image-3.10.104-8-osmc (8)”.
(Logs available at

OSMC proposes posting these messages on the Forum what I’m doing now.

I tried apt-get update, apt-get dist-upgrade, apt-get -f install, but without success.
Any proposals what went wrong and how to fix it?


No clues in log.

When you say without success, what did you see as the output?

Edit, I see:

Entpacken von vero2-image-3.10.104-8-osmc (8) ...
dpkg-deb (Unterprozess): Archiv-Element wird dekomprimiert: lzma-Fehler: komprimierte Daten sind beschädigt
dpkg-deb: Fehler: Unterprozess <Dekompression> gab den Fehlerwert 2 zurück
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/vero2-image-3.10.104-8-osmc_8_armhf.deb (--unpack):
 Unterprozess dpkg-deb --fsys-tarfile gab den Fehlerwert 2 zurück
Examining /etc/kernel/postrm.d .
Vorbereitung zum Entpacken von .../tzdata_2016j-0+deb8u1_all.deb ...
Entpacken von tzdata (2016j-0+deb8u1) über (2016d-0+deb8u1) ...
Fehler traten auf beim Bearbeiten von:

But I don’t understand what that means, it looks like it can’t extract the archive. This can happen if your connection is interrupted during the download or if there is an HTTP proxy.

Try apt-get clean or even removing the archive from /var/cache/apt/archives and re-run update and dist-upgrade.