Error message on Vero 4K+

I have the 2020.10-1 update installed on the Vero 4K+ . When it was offerered the update seemed to go well and we haven’t seen much in the way of messages in a wek or so. Today I got a popup that said “Error installing:\nPlease report this on the OSMC Forum” (the \n was actually a blank line)

Out of curiosity I forced an update check. The progress window said “1/4 items – 0 kBps – 0.0 / 0.0MB 0% \n Starting Download”. After a minute or two it gave up and popped up the “Error installing” message. It seems like it’s trying to find a list of updatable files perhaps, but can’t get the list?

It’s possible your internet connection dropped out momentarily when checking for updates. You can check again by going to My OSMC -> Updates -> Manual Controls.

The connection does seem to drop consistently. It’s the only device we have that reports an issue reaching the WiFi. The error is highly repeatable though. If I force a multiple checks, each one has the same issue.

The version I had previous to the October update was the June(?) version, and the download/update to October went without a complaint.


The release before October was indeed June.

My guess is you are up to date but sometimes a check will fail and give you that my message. I think that we should not display an error if an update check fails. What do you think?

Regarding WiFi connectivity – I’m happy to help you with that as a separate issue with logs.


That was my guess (it being updated and happy) as well. Where are the logs? I can retrieve them and start a new message.

Oh, and I’m not sure I’d do blanket suppression of messages if an update check fails. It could be a sign of something else. Maybe an option?


Perhaps we should just re-word the message. ‘OSMC could not check for updates at this time. This could be a connectivity problem. If this persists, please start a support request on the OSMC forums’.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

You can ignore the bit about enabling debug logging, as a WiFi issue won’t be related to Kodi.

The reword is better than what’s there now. I can imagine that a Vero 4K+ in the hands of someone not savvy would still be alarmed by that. What I’ve done with things I’ve designed commercially is - with daily checks that are kind of unimportant, I’d have it just ignore the first failure or two. Then if it happens regularly, that’s when i’d pop up the message. By default this check is daily, so perhaps if it happened daily for a few days, then complain? It’s not the same as trying to retrieve a file for an update you asked for.

Thanks for the log info. That failure happens when it’s trying to update info from the movie database. I’ll follow your instructions and post a message once I have logs.

Hi Sam. I’d definitely appreciate some sort of option to not display an error message. Regarding your comment about internet connection dropping momentarily…is this potential drop specific to the update process? Just curious as my vero’s internet connection (which has a vpn running) has on occasion shown a ‘busy’ status lately, forcing me to reboot to refresh the connection. Wondering if this is connected to the update failed messages I’ve been receiving? Thanks.

Nope – it’s just occasional.

Even if our update server is down for a minute a month – statistically, we’ll have a lot of people that see this message. We have an offset for user’s devices checking for updates because we’d otherwise get bombarded at the same time, despite having enough capacity if things were spread out a bit more. So if we’re down at 7:53PM on a Tuesday but back up by 7.54PM – a fair few people will see this message.

This is cosmetic and shouldn’t actually be causing a problem with your connection. It’s just Kodi being a bit slow to update connection status information. I’d be surprised if the connection is not actually available.

Ok, thanks for explaining.

I’ll add my vote to suppress these… It’s mind boggling that this error (Which the user can do nothing about) Will show even while video playback it’s happening!

This should not be the case with default update settings. There is default options set for update to only check when idle and also show prompts on the home screen.

Additionally if someone finds the update checker to be more frequent than their preference there are options in My OSMC to check less frequently as well as selecting a specific time of day it happens.

That’s definitely what my setting is, and I’ve seen the ‘error checking for updates’ error during playback on multiple vero 4k+ devices. I think it’d be better to just have a general ‘suppress errors’ option in that settings screen. What’s the point of telling a user about the error if there’s nothing to be done about it, anyway?