ERROR OSMC setting service failed to launch

#1

Hi,
while trying to update my VERO 2 via “My OSMC” I get “OSMC setting service failed to launch”, then sad face. “sudo apt-get update” leads to
osmc@osmc:~$ sudo apt-get update
Ign:1 http://ftp.debian.org/debian stretch InRelease
OK:2 http://security.debian.org stretch/updates InRelease
OK:3 http://ftp.debian.org/debian stretch-updates InRelease
OK:5 http://ftp.debian.org/debian stretch Release
OK:4 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Paketlisten werden gelesen… Fehler!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_stretch_main_i18n_Translation-en
E: Die Paketliste oder die Statusdatei konnte nicht eingelesen oder geöffnet werden.

Sorry, I can’t get any logs because of “My OSMC -> sad face”.

Somebody any idea what went wrong?

0 Likes

#2

try sudo apt-get clean

Sam

0 Likes

#3

Thanks for your fast answer.
sudo apt-get clean did not work, same result as before. Also deleting /var/cache/apt/archives/. did not help.

Regards Thomas

0 Likes

#4

Try:

sudo rm /var/lib/apt/list/*

0 Likes

#5

Ok, dit it.
SSH works, but shows error “Failed to retrieve unit: Failed to activate service ‘org.freedesktop.systemd1’: timed out”.
Tried to reboot, VERO says “sudo reboot
Failed to open /dev/initctl: Kein passendes Gerät bzw. keine passende Adresse gefunden
Failed to talk to init daemon.”
which means “found no aproppiate device or address”
Strange …

0 Likes

#6

That should be sudo rm /var/lib/apt/lists/* (lists with an s)

If possible, please post logs via SSH: grab-logs -A and provide the URL.

0 Likes

#7

Sorry for being away from keyboard for some days, there were other things to do first.

Did everything as you recommended.
After typing grab-logs -A via SSH the URL presented is https://paste.osmc.tv/ (strange, shouldn’t there be some cryptic letters and numbers instead of ?). System crashes from time to time (sad face) without any clear reason and restarts. TVHeadend HTSP Client Version 3.4.27 starts up but stays in starting procedure.
Videos played from local files run without problems.

Regards
Thomas

0 Likes

#8

The log is blank.

0 Likes

#9

Yes, I was afraid of that problem.
OSMV gives me - after SSHing “grab-logs -A” - an URL which is not specific (https://paste.osmc.tv/bracket ASCII 0x3C-html-bracket ASCII 0x3E). Instead of bracket-html-bracket I expected an unique sequence of letters and numbers to identify my upload. Seems that the upload mechanism fails somehow.

0 Likes

#10

That’s weird.
Can you reboot and try again?

0 Likes

#11

Of course.
But, I regret, same result.
Made a timestamp before and after:

So 17. Feb 19:51:03 CET 2019
osmc@osmc:~$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/
osmc@osmc:~$ date
So 17. Feb 19:51:42 CET 2019

0 Likes

#12

Okay. Try just uploading the Kodi log?

0 Likes

#13

Yes, of course.
How do I do this? Tried via “My OSMC”, but get “OSMC Setting Service failed to launch”. Where else can I find the logfile?

0 Likes

#14

Sorry, I’m a bit slow with LINUX. Finally found kodi.log. How do I upload? Upload button only accepts .jpg or .png or so.

Regards
Thomas

0 Likes

#15

Go to https://paste.osmc.tv and copy the contents in. You’ll get a URL from it.

Sam

0 Likes

#16

Did so. URL is https://paste.osmc.tv/mahozabege.vhdl.

0 Likes

#17

The log file is filled up with thousands of these entries:

20:58:50.393 T:2569450240 ERROR: SQL: [TV29.db] The database disk image is malformed

Best bet would be to delete this database and restart mediacenter. Not sure if its related to the original issue but this needs fixing.

0 Likes

#18

I was hoping I could avoid this. Alas …

0 Likes

#19

Ok, that seems to have solved the problem.
Deleted TV29.db, then sudo apt-get update, dist-upgrade and clean. KODI seems to be ok, TVHeadend has forgotten parts of its configuration. Logfile kodi.log looks ok.

Thanks a lot for your help!

1 Like