Error while updating OSMC

Hello,

I’m having trouble installing the latest update of OSMC on my raspberry pi
I get the following error message during install.

An error occured while installing the following package liblirc-dev (0.9.4c-9)

I tried several times and I always get the same error.

I tried installing it manually with apt-get install but I also get an error

Here is a link to my log file https://paste.osmc.tv/eperiheyuv

I tried installing vlc with hardware acceleration before that it might be linked ?

Thank you for your help.

Please run the following commands:

sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade

Your SD card might be having a few problems.

Thank you for your reply. I tried the commands but I still can’t install liblirc-dev.
This is what I get : (sorry it is in french…)

osmc@osmc:~$ sudo apt-get clean
osmc@osmc:~$ sudo apt-get update
Atteint:1 http://security.debian.org stretch/updates InRelease
Atteint:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Réception de:3 https://dtcooper.github.io/raspotify raspotify InRelease [1’706 B]
Ign:4 http://ftp.debian.org/debian stretch InRelease
Atteint:5 http://ftp.debian.org/debian stretch-updates InRelease
Atteint:6 http://ftp.debian.org/debian stretch Release
1’706 o réceptionnés en 33s (50 o/s)
Lecture des listes de paquets… Fait
osmc@osmc:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
liblircclient-dev : Dépend: liblirc-dev mais il n’est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
(ou indiquez une solution).
osmc@osmc:~$ sudo apt --fix-broken install
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Correction des dépendances… Fait
The following additional packages will be installed:
liblirc-dev
Les NOUVEAUX paquets suivants seront installés :
liblirc-dev
0 mis à jour, 1 nouvellement installés, 0 à enlever et 38 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 69.9 ko dans les archives.
Après cette opération, 221 ko d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ftp.debian.org/debian stretch/main armhf liblirc-dev armhf 0.9.4c-9 [69.9 kB]
69.9 ko réceptionnés en 0s (599 ko/s)
(Lecture de la base de données… 73396 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de …/liblirc-dev_0.9.4c-9_armhf.deb …
Dépaquetage de liblirc-dev:armhf (0.9.4c-9) …
dpkg: erreur de traitement de l’archive /var/cache/apt/archives/liblirc-dev_0.9.4c-9_armhf.deb (–unpack) :
tentative de remplacement de « /usr/include/lirc/lirc_client.h », qui appartient aussi au paquet armv7-lirc-osmc 0.9.0-6
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/liblirc-dev_0.9.4c-9_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
osmc@osmc:~$

It looks like you tried to install liblirc-dev on 2019-11-03 at 19:40:46. You’ll know why you did this but it conflicts with an OSMC package armv7-lirc-osmc, which is already installed. Usually, the conflict is that both packages want to install the same file or files.

dpkg: erreur de traitement de l'archive /var/cache/apt/archives/liblirc-dev_0.9.4c-9_armhf.deb (--unpack) : tentative de remplacement de « /usr/include/lirc/lirc_client.h », qui appartient aussi au paquet armv7-lirc-osmc 0.9.0-6

The simplest answer is not to install liblirc-dev, though I appreciate that doing so might cause dependency issues.

So if I undeerstand correctly liblirc-dev is not needed by osmc ? But why is osmc trying to install it with the update ?
I don’t need that package. I tried deleting liblirc-dev but it is not installed. Is there some way I can go through the update ? Or do I have to reinstall osmc ?

I’ve run a quick check on what gets installed with vlc and it doesn’t seem to install liblirc-dev, though liblirc-client0 does get installed.

Digging further, it seems that liblirc-dev is being installed as a dependency of liblircclient-dev, which appears in this command:

Start-Date: 2019-11-03  19:40:46
Commandline: /usr/bin/apt-get-real install liba52-0.7.4-dev libasound2-dev libass-dev libavahi-client-dev libavc1394-dev libbluray-dev libbz2-dev libc6-dev libcairo2-dev libcddb2-dev libcdio-dev libchromaprint-dev libdbus-1-dev libdc1394-22-dev libdca-dev libdirectfb-dev libdvbpsi-dev libdvdnav-dev libdvdread-dev libebml-dev libfaad-dev libflac-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev libgcc-6-dev libgcrypt20-dev libglib2.0-dev libgme-dev libgnutls28-dev libgpg-error-dev libgsm1-dev libjpeg62-turbo-dev libkate-dev liblircclient-dev liblivemedia-dev liblua5.2-dev liblzma-dev libmad0-dev libmatroska-dev libmodplug-dev libmp3lame-dev libmpcdec-dev libmpeg2-4-dev libmtp-dev libncursesw5-dev libogg-dev libopus-dev libpng-dev libpulse-dev libraw1394-dev libresid-builder-dev librsvg2-dev librtmp-dev libsamplerate0-dev libsdl-image1.2-dev libsdl1.2-dev libshine-dev libshout3-dev libsidplay2-dev libsnappy-dev libsndio-dev libspeex-dev libspeexdsp-dev libssh-gcrypt-dev libssh2-1-dev libstdc++-6-dev libtag1-dev libtheora-dev libtinfo-dev libtwolame-dev libudev-dev libupnp6-dev libva-dev libvcdinfo-dev libvorbis-dev libvpx-dev libwavpack-dev libwebp-dev libx11-dev libx264-dev libx265-dev libxcb-keysyms1-dev libxcb1-dev libxml2-dev libxvidcore-dev libzvbi-dev zlib1g-dev libgdk-pixbuf2.0-dev libgtk2.0-dev libnotify-dev libqt5x11extras5-dev libxi-dev libsmbclient-dev libxext-dev libxinerama-dev libxpm-dev libaa1-dev libcaca-dev libegl1-mesa-dev libgles1-mesa-dev libgles2-mesa-dev libxcb-shm0-dev libxcb-xv0-dev libxcb-randr0-dev libxcb-composite0-dev libavcodec-dev libavformat-dev libgstreamer1.0-dev libswscale-dev

If you didn’t knowingly install this package, then it was possibly brought in by something else.

All in all, whatever has triggered this chain of dependencies needs to be undone or, more likely, you’ll probably need to reinstall OSMC.