Errors were encountered while processing: /var/cache/apt/archives/armv7-diskmount-osmc_1.5.5_armhf.deb

I think this is a different issue than the one I encountered earlier: Errors were encountered while processing: armv7-diskmount-osmc - #3 by vinnl

So I encountered some errors when trying to upgrade to the new release using My OSMC. It told me to report it on the forum, so here we go :slight_smile: The APT logs are here:

The problem is you ran apt upgrade.

We block apt-get upgrade but seems we missed apt upgrade.
A backup + reinstall is probably the best approach.

You could try apt full-upgrade but I haven’t the foggiest if it will work.

It seems that at some point you may have been using the jessie-devel staging repository. You updated to some experimental (and not ready for prime time) packages on 8th September, so the issue is indeed unrelated to the other linked thread.

I still believe that unfortunately the best remedy is a reinstallation.
I would also recommend only using apt-get dist-upgrade or the My OSMC updating tool for system updates.


Hmm OK, that’s a shame, but I guess there’s not much else for me to do :slight_smile: I actually tried the upgrade because the system kept hanging, so I couldn’t upgrade from My OSMC.

I’d recommend reinstalling. If you still get hangs, start a thread and we’ll look in to that separately.


Will do, thanks :slight_smile: